• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

2000 Buick Park Avenue Coolant Temperature Sensor

avtechwx3

Member
49
5
8
Buick Ownership
1992 buick lesabre and 2000 buick park avenue
Hi Folks,

Looking to change the sensor. I have located it under the thermostat housing. Any tips on how to get it out?

Much Thanks
 

Boosted2004SC

Member
72
18
8
Iowa
Buick Ownership
2004 Park Avenue Ultra
That should be screwed directly into your lower intake manifold behind the thermostat housing, very easy to replace (look for wire running up behind thermostat housing), however your coolant will come pouring out so you might want to have your new one ready to screw back in quickly. I agree you may need to move some things out of the way, but hopefully not much.
 

avtechwx3

Member
49
5
8
Buick Ownership
1992 buick lesabre and 2000 buick park avenue
ok great. Yes, I was able to remove the wire and will use a nineteen mm deep socket with a half inch wrench. the only thing I had to move was the engine cover. I'll let you know tomorrow how it turns out. I'll be ready with the coolant release and thanks.
______________________________
 

avtechwx3

Member
49
5
8
Buick Ownership
1992 buick lesabre and 2000 buick park avenue
Hi Guys,

I got the sensor out no problem, some coolant leaked but nothing out of control. Installed the new sensor, connected wire. So I thought temp gauge would read lower but it didn't. It warmed up to about 215 220 and I am thinking that the temp senor is not the problem but for 22 dollars I am considering this a future job done now. Don't forget, this is the best vehicle I have ever owned and it is almost twenty years old with 183500 miles. The engine always ran at about 190 and then 205 when parking in the garage. It shouldn't be running this hot if it has no history of doing so.

Keep in mind, over the last few years I have changed the radiator and new coolant with that, changed the thermostat, the hoses, the radiator cap, and the fans are working. And now, new temp sensor installed. Why is this engine running hot? Only runs hot when stationary, not on the parkway and has never overheated. With that, I am ruling out head gasket or some other serious engine issue.

So then it hit me. As I am under the hood I realized this engine is not actually running hot. The temp gauge is indicating 210 to 220 and briefly hit 226 but the engine seems cool as does the cap. Could it be the temp gauge giving erratic readings?

I then took my laser pointer thermometer and pointed it at the upper radiator hose and the hottest reading I could get was at the point closest to the neck at the thermostat housing but on the hose. It read between 175 and 185. I pointed it at the thermostat housing itself and it read 207.

So my question would be: is the best place to measure coolant temperature at the top of the hose near the thermostat? I would think it would be because all other points were cooler. And I would also think that the thermostat housing itself would be hotter because it is receiving heat from points on the engine where as the hose is coolant running through it. And the last question is: is there another sensor on my 2000 year Buick that controls temp gauge? Temp gauge seems like the problem.


Thanks Much
 

Alan 55

Buick Newbie
Sustaining Member
312
102
43
Florida
Buick Ownership
2001 Buick Park Avenue, previously owned 1997 Park Avenue
Hi Guys,

I got the sensor out no problem, some coolant leaked but nothing out of control. Installed the new sensor, connected wire. So I thought temp gauge would read lower but it didn't. It warmed up to about 215 220 and I am thinking that the temp senor is not the problem but for 22 dollars I am considering this a future job done now. Don't forget, this is the best vehicle I have ever owned and it is almost twenty years old with 183500 miles. The engine always ran at about 190 and then 205 when parking in the garage. It shouldn't be running this hot if it has no history of doing so.

Keep in mind, over the last few years I have changed the radiator and new coolant with that, changed the thermostat, the hoses, the radiator cap, and the fans are working. And now, new temp sensor installed. Why is this engine running hot? Only runs hot when stationary, not on the parkway and has never overheated. With that, I am ruling out head gasket or some other serious engine issue.

So then it hit me. As I am under the hood I realized this engine is not actually running hot. The temp gauge is indicating 210 to 220 and briefly hit 226 but the engine seems cool as does the cap. Could it be the temp gauge giving erratic readings?

I then took my laser pointer thermometer and pointed it at the upper radiator hose and the hottest reading I could get was at the point closest to the neck at the thermostat housing but on the hose. It read between 175 and 185. I pointed it at the thermostat housing itself and it read 207.

So my question would be: is the best place to measure coolant temperature at the top of the hose near the thermostat? I would think it would be because all other points were cooler. And I would also think that the thermostat housing itself would be hotter because it is receiving heat from points on the engine where as the hose is coolant running through it. And the last question is: is there another sensor on my 2000 year Buick that controls temp gauge? Temp gauge seems like the problem.


Thanks Much
Thanks for the detailed info that you provided. I have a 2001 Park Avenue and will be doing some under hood work in the next few days. I will use my laser pointer thermometer to check some readings and will post the results of the temperatures.
 
Turbo Buick Badge
Top