2000 Buick Regal starts for 3 seconds then stalls

waldolandry

Buick Newbie
5
0
0
Buick Ownership
Buick
Ok, I have a proplem with my 2000 Buick Regal. It will start right up but only runs for 3 seconds then stalls out as if I just turned off the key. I had a similar problem not long ago and may have replaced the maf sensor or fuel pump relay not sure. I tried a lot of stuff untill it worked again might have replaced both. Also after the car dies it makes a weird clicking noise from the relay box. Any ideas? Any help would be greatly appreciated
 

Kevandkaye

Full Member
1,056
5
38
Florida
Buick Ownership
'99 Ultra, 2014 Regal T
Try unplugging the MAF sensor connector and see what happens. If it runs good, you can drive it to a parts store for a new MAF sensor. I had one go bad on me ONE day after replacement. They gave me another (I was mad!)
 

waldolandry

Buick Newbie
5
0
0
Buick Ownership
Buick
I tried that and it did the same thing. I might try resetting the computer and try it again. Its baffled me so far, also listened and the fuel pump seems to be firing up too. Just replaced plugs and wires not long ago, Im thinking its either the fuel filter or maybe fuel pump relay again. I just hope I can get out of a tow to the shop.
 

planenut_2000

Full Member
336
5
0
Buick Ownership
Buick
Is this a superchargerd regal? If it is supercharged, then the fuel pump is a dual pressure pump. It gets the dual pressure by running the power to it through a resistor assy. When the car is cranked you get full voltage to the pump, and as soon as you release the key and the engine starts, the voltage goes through the resistor assy for a lower pressure operation. That resistor assy has been known to corrode and become defective thus not allowing no power thru to the pump and resulting in your stall. The resistor is located in the RH fender area. The replacement from GM will relocate it to a more corrosion free area.
______________________________
 
Last edited:

waldolandry

Buick Newbie
5
0
0
Buick Ownership
Buick
Thank you for all of the help! I have bypassed the resistor for now and ordered a new one from the dealer. Should be in tomorrow morning. 60 bucks will be worth knowing my fuel pump isnt running high speed all the time. Thank you Buick forum!!
______________________________
 

Dakota Bzdon

Buick Newbie
1
0
0
Buick Ownership
Buick
I have a similar problem I have a 1996 buick park ave it will start then die instantly some times if I put it in drive and press gas it will start but it's been doing it now everyday it will not stay on longer than 5 swconds even with gas all the way to the floor I cannot figure it out
 

tmanp

Full Member
78
0
6
Buick Ownership
2006 Buick Lacrosse CXL 3800 S3 V6- 150,000 mi
My 3800-powered Lacrosse did a similar thing as op's. I cleaned the throttle body and that eliminated the problem. (not every start, just some)
 

HotZ28

Full Member
8,097
766
113
Buick Ownership
1996 Roadmaster Limited Collectors Edition 58k - 1996 PAU
I have a similar problem I have a 1996 buick park ave it will start then die instantly some times if I put it in drive and press gas it will start but it's been doing it now everyday it will not stay on longer than 5 swconds even with gas all the way to the floor I cannot figure it out
Does the security light come on and blink during the first bulb check for 3-sec when you first to the ignition ON, or does it continue to stay ON? If not a security problem, have you tried disconnecting the MAF to see if it will start?
 

G-652526

I have a 2000 buick regal 3.8L no CEL cold start stays running. warm start strarts then dies, unless i hold my foot on the gas then runs normal.
______________________________
 

Aphex

New member
5
0
1
I have a 2000 buick regal 3.8L no CEL cold start stays running. warm start strarts then dies, unless i hold my foot on the gas then runs normal.
Could be a number of possoble issues but if you still need help we can get it resolved. After the condition happens, but with the car off, pull the vacuum line coming off the FPR. If fuel seeps out or the smell is present this is likely your issue. If not, there are other things to test and check.
 

rtabish

Full Member
37
1
8
Missoula, Montana
Buick Ownership
1993 Buick Century Custom
I am having a similar issue with my 98 GS w/supercharger. It will run fine...even great, but every once in a while I will start it cold, run an errand where I drive for a ways [10 or 15 miles] and if I shut the car off, it will do the same thing. Start, chug like it is gas starved, and then die...and it won't start up properly unless it sits for a while cooling down. There are two relays controlling the fuel pump, located in the fuse/relay box under the hood on the passenger side. One is for [I think] normal fuel pump use, and the second is for controlling the speed of the pump under load for the supercharger [from what I have been able to figure out]. There is an inline resistor that is supposed to work with the second relay, located in front of the passenger front wheel well, on the frame rail next to or behind the windshield washer pump reservoir. Planenut_2000 has explained this as well farther up in this post.

My problem is, I can not seem to find a replacement resistor. I have contacted every parts store in my town. The only one who had one listed in their parts catalog was O'Reilly's, but it is apparently a special order item that the parts guy I talked to didn't know was even carried any more, and he had to put in a special request to see if it was available. The local Buick Dealership parts guy said that their catalog listed such a part, but that it came as a kit...I assume meaning I would have to put it together from scratch.

There are links to articles and videos explaining a work-around involving modifying the second relay to bypass the resistor, but that forces the fuel pump to run at high speed full time. Not something that seems prudent, and I would rather fix it properly. All the information I have found online for this issue is from several years back, and the discussions that had links to where to find the resistor are obsolete. I was wondering if anyone had a more up to date source for this part. Thanks.
 

rtabish

Full Member
37
1
8
Missoula, Montana
Buick Ownership
1993 Buick Century Custom
Last edited:
Get your turbo buick badge right here!
Top