2006 Rendezvous crank but no start

5
0
1
Buick Ownership
2006 buick rendezvous
I have a 2006 buick rendezvous. I had a problem a couple weeks ago with not starting. I could start it on starter fluid. I changed out the fuel pump, and still didnt get start so I went to the connector that fuel pump connects to, the one behind drivers seat. It was bad with corrosion and pins all broken. I took it out and direct wired everything. It ran great for a couple days. Then it wouldn't start again. I check relay and fuse. I cannot hear the fuel pump prime anymore. It just cranks. Has anyone else had this problem so I know where to look.
 

MelsRegal

Full Member
2,113
115
63
Buick Ownership
Regal GS 2017
so if the pump is receiving power at that connector either the pump has a bad ground or the pump is bad or there is a break between that connector and the pump. What happens if you run power directly to the pump.
______________________________
 
5
0
1
Buick Ownership
2006 buick rendezvous
so if the pump is receiving power at that connector either the pump has a bad ground or the pump is bad or there is a break between that connector and the pump. What happens if you run power directly to the pump.


I tried running a wire from battery to the wire behind the connector and it did the same thing. Just crank and not fire. Pump didnt turn on
 
1
0
1
Buick Ownership
2006 Rendezvous
I have a 2006 buick rendezvous. I had a problem a couple weeks ago with not starting. I could start it on starter fluid. I changed out the fuel pump, and still didnt get start so I went to the connector that fuel pump connects to, the one behind drivers seat. It was bad with corrosion and pins all broken. I took it out and direct wired everything. It ran great for a couple days. Then it wouldn't start again. I check relay and fuse. I cannot hear the fuel pump prime anymore. It just cranks. Has anyone else had this problem so I know where to look.
My rendezvous no start was the ignition key harness area. Had to replace the cylinder key and harness. if over 130 miles car key and harness gets wore out. Also if you changed a battery or alternators you may have a power short near the battery area. If any electrical connection was worked on recently it could be loose, Check battery cranking aps the CCA of the battery. Check the alternator for condition. Check the starter wire connections for dirt. Clean starter cable ends both ends. Put car in neutral and hot start starter with screw drive or a start switch to solenoid to power on starter. If starter does not start it is the starter. If it turns over. it is not the starter. Put car in N not D and try to start car. If pump sounds it may be ignition are like I said.
 

Zeroboostbuick

Active member
674
145
43
S.W. Ontario Canada
Buick Ownership
2018 Regal Sportback - 2010 Yamaha R6 (track bike) Past cars: 92 LeSabre, 98 Regal, 02 GrandPrixGT
Good idea to try starting from Neutral. Worth a try,... You never know.

But it sounds to me like it could be the fuel pump relay.
 
5
0
1
Buick Ownership
2006 buick rendezvous
Good idea to try starting from Neutral. Worth a try,... You never know.

But it sounds to me like it could be the fuel pump relay.


I tried it in neutral first thing. I replaced relay and fuse also thinking it was one of them since it's a new fuel pump
______________________________
 
5
0
1
Buick Ownership
2006 buick rendezvous
Connector at fuel pump is getting power. It still doesn't turn on. I hooked a spare battery up just to see if the pump would turn on. The pump does turn on with just a power and ground connecting from battery. What should I do now
 

MelsRegal

Full Member
2,113
115
63
Buick Ownership
Regal GS 2017
just to be clear when you turn the key on the pump runs only about 5 seconds and then the power cuts off. So the pump works with direct power so how can you say the "connector at fuel pump is getting power", it cannt be both.
 
674
145
43
S.W. Ontario Canada
Buick Ownership
2018 Regal Sportback - 2010 Yamaha R6 (track bike) Past cars: 92 LeSabre, 98 Regal, 02 GrandPrixGT
I wonder if the ECM is to blame.

Have you tried switching the relay with another one to verify the relay is good ?
______________________________
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top