2009 LAX - Front end noise

NittanyDoug

Full Member
111
3
18
Buick Ownership
Buick
2009 LAX CXL with 105,000 miles. I don't know what suspension, FE1 or FE2. I get a noise from the driver's side front when going over potholes even at slow speeds. Last night I replaced the sway bar end links with new MOOG ones. This morning I still have the sound. All struts were replaced less than 10,000 miles ago. While up on a jack, the wheel doesn't move left/right or top/bottom. Lug nuts are tight.

I was thinking perhaps it could be sway bar bushings maybe but I have no idea what size sway bar it is to order new ones.

Any suggestions?

TIA.
Doug
 

NittanyDoug

Full Member
111
3
18
Buick Ownership
Buick
I figure I"ll replace both. Just need to order them. Outer Tie-rod ends at the same time? Suggestions on the rear rattle that it's had since I got it at 8,000 miles? Back passenger side. I thought it was something in the trunk and the spare tire is tight. When i changed the struts everything looked to be in good shape and tight. Next step i guess is sway bar links back there.
______________________________
 

NittanyDoug

Full Member
111
3
18
Buick Ownership
Buick
I did the offending side today. Sure enough the sound is gone. Pretty sure it was the control arm. The from bushing actually fell out when I pulled the arm out. It came apart relatively easy. Hardest part was the ball joint. Getting the new one back in place and lined up. I gave up and it's about 30 degrees off of where is idea for future pin removal.

I'll do the passenger side next weekend and then get an alignment. I don't drive much during the week.
 
Get your turbo buick badge right here!
Top