2011 Buick Lacrosse CXL P0420 and P0430

22
3
3
Buick Ownership
2011 Buick Lacrosse
My lacrosse has about 107,000 miles. I had no problems until a month after I had my spark plugs changed. I would get code P0420 I reset it and it wouldn't come on until about 600 miles later this happened twice. So in between the first and the last time i used cataclean to see if that would work. Like I said the light came on for code P0420 about 600 miles later. Now day before yesterday the code came on so i reset it. And today it came on with code P0420, P0430. Im wondering is it the Cat, 02 sensors, NGK spark plugs that were installed, Leak in the intake gasket when installing the spark plugs.
 

MelsRegal

Full Member
2,113
115
63
Buick Ownership
Regal GS 2017
Below are all the causes of P0420. Were the spark plug gaps checked? Were the correct NGK plugs installed? Installing plugs has nothing to do with the intake gasket.
Leaded fuel was used where unleaded was called for (unlikely)
A damaged or failed oxygen / O2 sensor
Downstream oxygen sensor (HO2S) wiring damaged or connected improperly
The engine coolant temperature sensor is not working properly
Damaged or leaking exhaust manifold / catalytic converter / muffler / exhaust pipe
Failed or underperforming catalytic converter (likely)
Retarded spark timing
The oxygen sensors in front and behind the converter are reporting too similar of readings
Leaking fuel injector or high fuel pressure
Cylinder misfire
Oil contamination
 
22
3
3
Buick Ownership
2011 Buick Lacrosse
Below are all the causes of P0420. Were the spark plug gaps checked? Were the correct NGK plugs installed? Installing plugs has nothing to do with the intake gasket.
Leaded fuel was used where unleaded was called for (unlikely)
A damaged or failed oxygen / O2 sensor
Downstream oxygen sensor (HO2S) wiring damaged or connected improperly
The engine coolant temperature sensor is not working properly
Damaged or leaking exhaust manifold / catalytic converter / muffler / exhaust pipe
Failed or underperforming catalytic converter (likely)
Retarded spark timing
The oxygen sensors in front and behind the converter are reporting too similar of readings
Leaking fuel injector or high fuel pressure
Cylinder misfire
Oil contamination

Wow thats a lot of causes for that those codes. The NGK were the correct plugs, I did not install them my mechanic did so could not elaborate on the gap. This is the first time i had both codes show up at the same time. I sure wish its just the oxygen sensors.

So there could be leaking fuel/ pressure? I will be changing my oil tomorrow. Im at 5000 miles . I Thought about the oil could or maybe have something to do with the codes but I was not sure. But im not sure how likely that is.. I bought a bottle of cataclean, When i poured it in my car i drove it for a while. Amazingly I was getting 30 + MPG.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top