2011 Buick LaCrosse CXS rear windows and doors issue codes U154A and U1548

Sstevieboy0208

Buick Newbie
23
3
3
Cincinnati Ohio
Buick Ownership
2011 Buick Lacrosse
I have a 2011 Buick LaCrosse CXS and all of a sudden my rear windows stopped working they won't work from the master switch or from the actual individual switch and strangely at the same time the rear doors won't trigger the dome lights when open nor a message on the dash that they're open. Basically as if the car not recognizing the the back 2 doors at all. I checked fuses and relays and no luck. Any tip or help to guide me in the right direction will be greatly appreciated. Thank you all.
 

Chris Heinen

New member
28
8
3
Buick Ownership
2010 LaCrosse CX
That's a puzzler. The following OEMDTC bulletin doesn't specifically mention Buick, but the codes/symptoms match...

 

Sstevieboy0208

Buick Newbie
23
3
3
Cincinnati Ohio
Buick Ownership
2011 Buick Lacrosse
That's a puzzler. The following OEMDTC bulletin doesn't specifically mention Buick, but the codes/symptoms match...

Some of the symptoms are in that thread. I will get to it today and post the results. Thank you
 

2007LucerneCXL

Full Member
1,828
520
113
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
Codes U154A and U1548, is U154A a U1544? Also on most GM it's the master control in the driver's door that the wiring harness connections control for passengers windows run through so that may need to be checked. Control and harnesses may be a option to consider looking at.

This is why I asked about the one code#
Service Information
______________________________
 

Sstevieboy0208

Buick Newbie
23
3
3
Cincinnati Ohio
Buick Ownership
2011 Buick Lacrosse
Codes U154A and U1548, is U154A a U1544? Also on most GM it's the master control in the driver's door that the wiring harness connections control for passengers windows run through so that may need to be checked. Control and harnesses may be a option to consider looking at.

This is why I asked about the one code#
Service Information
U154A Is present but not 1544. But will keep that as a second option. Thank you I truly appreciate all inputs but the first one have more symptoms that I have which makes me lean towards it.
 

HotZ28

Full Member
6,747
218
63
Buick Ownership
1996 Roadmaster Limited Collectors Edition 58k - 1996 PAU
U154A 00​
(K9 Body Control Module) LIN Bus 4 Lost Communication With Device 10 (S79RR Window Switch - Left Rear)
U1548 00​
(K9 Body Control Module) LIN Bus 4 Lost Communication With Device 8 (S79LR Window Switch - Right Rear)
 

Sstevieboy0208

Buick Newbie
23
3
3
Cincinnati Ohio
Buick Ownership
2011 Buick Lacrosse
U154A 00​
(K9 Body Control Module) LIN Bus 4 Lost Communication With Device 10 (S79RR Window Switch - Left Rear)

U1548 00​
(K9 Body Control Module) LIN Bus 4 Lost Communication With Device 8 (S79LR Window Switch - Right Rear)
So does that mean that it is the master switch lost communication to the 2 rear ones ?
 

2007LucerneCXL

Full Member
1,828
520
113
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
That may be the first place to check as it's something common on GM's when the MC isn't working it will cut out other windows functions. If not you can check the other list posted.
______________________________
 

2007LucerneCXL

Full Member
1,828
520
113
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
Yeah that's a head scratcher, I'm not familiar with the harness layout, but I believe the door actuator handles door open trigger lights and warnings. There was a recall on the 2014 Lacrosse on a splice in the driver's door that had different items not working because of corrosion, but seems it might be a different problem on yours.
______________________________
 

Sstevieboy0208

Buick Newbie
23
3
3
Cincinnati Ohio
Buick Ownership
2011 Buick Lacrosse
Yeah that's a head scratcher, I'm not familiar with the harness layout, but I believe the door actuator handles door open trigger lights and warnings. There was a recall on the 2014 Lacrosse on a splice in the driver's door that had different items not working because of corrosion, but seems it might be a different problem on yours.
Well I found out that it's all one circuit so I will check the switch then the harness. My guess is that if the back 2 doors have no power to them that will cause all since it's on circuit supply for all
 

nglauer

New member
3
0
1
Buick Ownership
2013 Buick Lacrosse AWD
Did you happen to take your car into the dealership? I don't mean to hijack your thread, I just purchased a 2013 Lacrosse AWD with a some what similar problem. My driver's switch doesn't illuminate and the only switch that works is the drivers window. Also, the mirror switch doesn't work. Oddly though, the windows all work from their own switches? I purchased a new GM switch and had the exact same results. I haven't tried a replacement mirror switch yet, but believe I'll have the same outcome. I am hoping your findings may be relevant to my issue, even though they are slightly different. I did have a lot of water in my driver's floor board, probably 1-2 gallons? I'm not sure how it got there, but it was extremely wet. I'm hoping it's not an issue with the wiring harness (assuming the one running back the drivers floor is related to the passenger switches). As a side note, my door locks work fine.

Thanks!
Nick
 

Sstevieboy0208

Buick Newbie
23
3
3
Cincinnati Ohio
Buick Ownership
2011 Buick Lacrosse
Did you happen to take your car into the dealership? I don't mean to hijack your thread, I just purchased a 2013 Lacrosse AWD with a some what similar problem. My driver's switch doesn't illuminate and the only switch that works is the drivers window. Also, the mirror switch doesn't work. Oddly though, the windows all work from their own switches? I purchased a new GM switch and had the exact same results. I haven't tried a replacement mirror switch yet, but believe I'll have the same outcome. I am hoping your findings may be relevant to my issue, even though they are slightly different. I did have a lot of water in my driver's floor board, probably 1-2 gallons? I'm not sure how it got there, but it was extremely wet. I'm hoping it's not an issue with the wiring harness (assuming the one running back the drivers floor is related to the passenger switches). As a side note, my door locks work fine.

Thanks!
Nick
Mine the rear windows are not working at all. And I think there might be a harness that got disconnected as well as I have never had the issue with water inside the car. but I will keep you posted on my finding as this next few days I might have the time to take another look before I take it to the dealership.
______________________________
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top