2013 Buick Enclave air bag service light randomly comes on

akclarkson1976

New member
6
0
1
Buick Enclave 2013
My service air bag light will randomly come on but then turns back off. Sometimes it stays on for 20 seconds, sometimes for minutes, but never is always on. I talked to service guy at dealership I go to and he said they can do a diagnostic for $169 and they will see if they can find what's wrong. I find it odd that it goes off & on as though it's more of a loose wire/connection vs an actual problem. But of course don't want to risk a faulty airbag either! My model is not included in the recall I found online, but also am concerned it has the same issue, even if not part of the recall. Any ideas?
 

Bonze72

Member
79
11
8
Lesabre
Is your drivers seat trim broke by chance like where your power seat controls are
______________________________
 

mtbsteve

New member
8
3
3
2014 Enclave Leather AWD
I have the same issue. Just kicked on 2 weekends ago in cold temps while up in NH. Went away for about the first 75 miles driving back to MA then will not go off. I scanned for codes, no codes found. Based on limited research so far, seems there was a recall for airbags on models up to 2013. I believe this is covered with my platinum warranty but based on others, hard to find the fault since it doesn't throw a code to help speed up diagnosis. This is on a 2014 with 60k miles, owned since new.
 

akclarkson1976

New member
6
0
1
Buick Enclave 2013
I have the same issue. Just kicked on 2 weekends ago in cold temps while up in NH. Went away for about the first 75 miles driving back to MA then will not go off. I scanned for codes, no codes found. Based on limited research so far, seems there was a recall for airbags on models up to 2013. I believe this is covered with my platinum warranty but based on others, hard to find the fault since it doesn't throw a code to help speed up diagnosis. This is on a 2014 with 60k miles, owned since new.
I think I have narrowed it down to the passenger air bag. It only comes on if someone is in the seat or if I have items in it. But it still only comes on for a short time and not every time. Guess that means I need to get codes read for the passenger air bag and go from there?
 

mtbsteve

New member
8
3
3
2014 Enclave Leather AWD
I think I have narrowed it down to the passenger air bag. It only comes on if someone is in the seat or if I have items in it. But it still only comes on for a short time and not every time. Guess that means I need to get codes read for the passenger air bag and go from there?
Check under the drivers seat. Per this discussion, the airbag connector is yellow. I will be checking mine later today. Hopefully it is just a loose connection that can be remedied at home.
https://www.buickforums.com/threads/airbag-light-turns-off-and-on.23165/#post-247883
______________________________
 

akclarkson1976

New member
6
0
1
Buick Enclave 2013

mtbsteve

New member
8
3
3
2014 Enclave Leather AWD
Hmm, not sure why, the link isn't working for me either. I will delete it so others don't try to click it.

Anyway, there were no step by step instructions. Just a general thought that there are connectors under the driver and passenger seats. Check to see if one might be loose. If the wire gets caught on something and then moved it could pull out of the connector. A TSB was issued for some models and years because it looks like the cables were too short so moving the seat could cause it to loosen. At least this is a quick check.
 

akclarkson1976

New member
6
0
1
Buick Enclave 2013
Hmm, not sure why, the link isn't working for me either. I will delete it so others don't try to click it.

Anyway, there were no step by step instructions. Just a general thought that there are connectors under the driver and passenger seats. Check to see if one might be loose. If the wire gets caught on something and then moved it could pull out of the connector. A TSB was issued for some models and years because it looks like the cables were too short so moving the seat could cause it to loosen. At least this is a quick check.
Great, thanks for your help!
 

mtbsteve

New member
8
3
3
2014 Enclave Leather AWD
Just had mine fixed yesterday at the dealer, it was the passenger side. There was a code shown that they could access that I could not see on my scanner, I can get it from the paperwork if someone wants it, my wife has the car now so it will be a bit. Mine is a 2014, 61,XXX miles and it was a completely free fix. Based on the feedback from the service writer, it looks like they performed the fix in the link below. They basically add solder to crappy connector pins. I remember seeing in other TSBs that they would cut out the connector completely and just solder the wires together.
It could always be something else but most people I have read about online seem to point back to the connectors and pins.

https://static.nhtsa.gov/odi/tsbs/2014/SB-10057064-3254.pdf
______________________________
 

Bonze72

Member
79
11
8
Lesabre
Mine is and I’m having that same issue!
The seat belt pretensioner wire is rite under the trim your probably moving them getting in and out of the seat you’ll have to replace the trim about 80$ from a dealer and make sure it’s still connected good it’s in the left rear corner of the seat close to the tracks
 
Get your turbo buick badge right here!
Top