99 century transmission issue

wcsquiresiv

Buick Newbie
2
0
0
Buick Ownership
Buick
Hi all,

I am an at home mechanic and my parents have a 1999 century that is having some transmission problems. The transmission mechanic can't diagnose until he gets into it and seems to be pushing for a complete rebuild. My parents had the transmission rebuilt about 30,000 miles ago and from the symptoms I don't think that the problem requires a rebuild.

Here are the symptoms: When you first put the car into drive (overdrive) and try to pull away, the car revs and hardly moves (shakes a little) as if it is actually in the overdrive gear. Pull it down into third, same thing; second same thing (but better as if it is in second gear); first and it starts normally, but now your locked in first and have to shift up from there. Come to a stop and the whole thing starts over again. When in second and moving at 20mph I got it to downshift into first by flooring it, when I let off it went back into second.

This seems to me like a shift solenoid, valve body, computer problem, loose wire, or something like that, not a complete transmission rebuild. I guess it could also be just a clogged filter.

Had anyone seen this before? Any ideas?

Any help would be appreciated

Thank You
 

nfldriver

Full Member
13
0
0
Buick Ownership
Buick
Your problem sounds exactly like mine. (99 buick century). I have a post up, It's titled "Transmission problems, need some advice." I had my pan dropped and filter replaced, but that didn't fix the problem. The mechanic who replaced my filter said it was very dirty and partially clogged, but again - the replacement didn't solve my problem. I haven't tried anything else yet because I want to see if anybody on here could help me narrow it down. I also have been given the Torque Converter as a possible culprit.
 

wcsquiresiv

Buick Newbie
2
0
0
Buick Ownership
Buick
Sorry about the lengthy delay, I just plain forgot.

My dad took the car to another transmission specialist. Unfortunately, I don't know all the details, we were suspecting the transmission range sensor, but that wasn't it. The guy ended up doing an entire rebuild. I was hoping to avoid that, and still don't believe that it was necessary, but it was my dad's decision.

Sorry that this post probably won't help anyone else.
 

g_424314

My buick the transmission , went i but it in gear to drive, I get whine noise and it won't move. Blow white smoke . But I can drive backwards fine. Mechanic told I small leaks, just checked the fluids and still doing it. Frustrating
 
Top