A/C works intermittently

Brutedawg20

Buick Newbie
4
0
1
Buick Ownership
Buick
2 days after the valve cover was replaced and oil pan was resealed for oil leaks. The a/c stopped working all of the time. Sometimes it works sometimes it doesn't. Just drove it on a weekend trip. On the way out it worked for about an hour and a half and the stopped and would not work again, until the following day. Last week it would stop halfway to a 12 mile drive to work. Took it in once to have it looked at they did an inspection and made sure there was refrigerant and no leaks. Any thoughts? It's a 2014 with 55,000 miles on it. Thanks.
 

GoMich

Full Member
66
0
6
Buick Ownership
Buick
Check AC pressure switch wiring harness . Someone may have bumped the connector working on your valve cover. Or switch itself may have gone bad.
 

Brutedawg20

Buick Newbie
4
0
1
Buick Ownership
Buick
Following up on this ac thread from last year. We ended up having the condenser replaced. Not under warranty and it cost us $1000. Ac works fine now but it squeaks when the condenser kicks on. It did it prior to the replacement parts as well. I’m told it’s the clutch. The service advisor said it’s not an issue. Other than I don’t think my three year old car should sound like an ice cream truck. I thought they were going to fix it when they replaced the condenser, but no. And last year I was tired of dealing with them and left it.
Now that it’s getting warm again I want to get it fixed. Anyone have this issue?
______________________________
 

GoMich

Full Member
66
0
6
Buick Ownership
Buick
do you have an old original accessory belt on car? If you do, try to replace the belt. Its a cheap thing to do that may be squeaking. Also it may be a belt tentioner, where the belt is not tight enough when compressor kicks in. Condenser is just a coil pack, it has no moving parts. I would try to replace belt first.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top