Battery dies, radio goes in and out

Thread starter #1

Manda87

New member
2
0
1
I have a 2013 Encore and have only had it for about 6 months. The battery has died on numerous occasions. Most recently, I was driving home from work (about 45 minute drive), stopped and had the car off for less than 5 minutes and it wouldn't start back up. The dash and everything lit up and the radio came on but it just clicked when i tried to start it. Anyone else with similar issues and possible fixes?

Also, the stupid stereo system. Lately, while driving the stereo regardless of its mp3, CD, or the radio itself, will cut in and out and turn off by itself. Eventually it will come back on but takes a bit. Any ideas on how to fix it? I've called intellilink and they cannot fix or troubleshoot the system.

Thanks in advance! I'd really like to be able to drive it again :(
 

MelsRegal

Full Member
2,279
149
63
Buick Ownership
Regal GS 2017
You need the battery load tested, the charging system tested and a test for a parasitic drain.
Do you have a factory radio? In either case it sounds like a bad connection and that can be difficult to find. The unit has to come out and the connections checked and there is no guarantee that the issue isnt internal to the unit.
 

HowY

Junior Member
27
0
1
Buick Ownership
Buick
(-:

it’s a fine FINE head unit and stereo sound

... if you grew up on earbudz ....

and dont mind the modern ‘glitches’

Welcome to the Forum!
 
Thread starter #4

Manda87

New member
2
0
1
You need the battery load tested, the charging system tested and a test for a parasitic drain.
Do you have a factory radio? In either case it sounds like a bad connection and that can be difficult to find. The unit has to come out and the connections checked and there is no guarantee that the issue isnt internal to the unit.

Thanks for the reply! Battery tested fine but I replaced it anyways and so far so good. Now onto the radio! *fingers crossed*
______________________________
 

KSDeputy

Full Member
341
2
18
NE Kansas
Buick Ownership
Buick Encore
My 2014 Premium just started doing that. They had it three days, replaced the battery etc. and said it was fixed. It started doing it again. It was towed to the dealer yesterday. It has less that 15,000 miles on it. If they can't fix it this time, I am trading it off. Up until it started doing this I really liked the car, but we live in the country and I must have a dependable vehicle.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top