Buick century issues

Knightsquire74

New member
2
0
1
Century
I own a 2002 century. It currently has a lurching issue when stopped. It also looses power on acceleration and in normal running. Neither parts stores nor mechanics scans pull up codes. Neither of them could tell me why it was lurching. I then called a dealer service department. They told me to change the ignition module and coils. I have done so. Still have same issue. I have even used the rest types suggested. Still not working. Please help. Thank you for any and all help.
 

chem_man

Buick Newbie
41
10
8
Fallston, MD
1999 Century
As MelsRegal said, check your fuel pressure. Your fuel pump might be on it's way out. I had identical symptoms to yours 2 years ago. First time I tested the fuel pump pressure, it was only 1 psi below the normal of 41 - 47 psi. 6 weeks later, it was down to 34 psi, well below the minimum spec pressure of 41 psi.

In went a Delphi fuel pump and car runs like new again. No more lurching, no more lack of power.

Good Luck!
 

Duckland23

Buick Newbie
42
3
8
Buick
As MelsRegal said, check your fuel pressure. Your fuel pump might be on it's way out. I had identical symptoms to yours 2 years ago. First time I tested the fuel pump pressure, it was only 1 psi below the normal of 41 - 47 psi. 6 weeks later, it was down to 34 psi, well below the minimum spec pressure of 41 psi.

In went a Delphi fuel pump and car runs like new again. No more lurching, no more lack of power.

Good Luck!
Yeah when the fuel pump gets weak she hard starting and gives you all sort of problems like hard starting from sitting for about 20 minutes longer cranking times too .
______________________________
 
Get your turbo buick badge right here!
Top