Car sputtering when i stop car.

Ronron01

New member
2
0
1
Buick Ownership
2011 buick cxl
I had the cam solenoid replaced both of them still doing the same thing no codes popping up.
 

2007LucerneCXL

Full Member
2,404
725
113
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
Fuel injector, spark plugs, fuel filter it's a list of items. If a hands on shop can't trouble shoot it, there's not much someone online can do with the minimum amount of information provided.

How was the cam solenoids decided on as the possible problem?
______________________________
 

g_681132

Fuel injector, spark plugs, fuel filter it's a list of items. If a hands on shop can't trouble shoot it, there's not much someone online can do with the minimum amount of information provided.

How was the cam solenoids decided on as the possible problem?
It had a code at the time.They repaired it the code went away.But when I come to a complete stop the car sputters. When I take it back to the shop who repaired it.They can't reproduce the sputtering. What causes this without producing a code.
 

MelsRegal

Full Member
2,791
278
83
Buick Ownership
Regal GS 2017
Why cannt you go for a drive with them to show them the issue just in case they dont clearly understand what you mean by "sputtering".
 

2007LucerneCXL

Full Member
2,404
725
113
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
The vehicle had a problem and had a code, the shop replaced cam solenoids and you still have the same problem as when you first brought it in, is that what's happening.

What did the shop say was the Code# as it could point to what else may have been involved. Remember no one on the forum can see, hear or feel your vehicle so as much detail as possible helps.
 

LARRY70GS

Full Member
2,065
108
63
Oakland Gardens, N.Y.
Buick Ownership
98 Riviera, 70 GS455 Stg1
Is it trying to stall as you come to a complete stop? Maybe the code had nothing to do with that problem and was coincidental. I wonder if you have a problem with the torque converter clutch not releasing when it should. Just an idea.
______________________________
 

BoostedRegal2.0

Active member
561
219
43
Buick Ownership
2014 Regal 2.0 Turbo AWD Trifecta Tune
It could be a clogged fuel injector; that won't throw an error code.

A fuel system cleaning done by the dealer or a repair shop will fix that. How many miles are on your car?
 

CLE12GS

Junior Member
146
28
28
Cleveland
Buick Ownership
2012 Buick GS
With High Pressure Fuel Pump running on a Lobe from the end of the Cam, maybe the lobe is worn down or the Fuel Presure is not high enough or efficient enough to keep it running at idle speed.
 

CLE12GS

Junior Member
146
28
28
Cleveland
Buick Ownership
2012 Buick GS
I have a 2012 GS with a 2.0L with a HPFP on the Motor pushing 55+psi Direct Port Injection, Not sure if the 2.4 is running that or if it's in the tank. I would do a Fuel Pressure check. There is a Sending unit in the tank, for fuel level.
______________________________
 

Attachments

Top