Charging system failure on my 2008 Buick 3.8L

Danable

New member
1
0
1
Buick Ownership
Lacrosse
So the car was running fine. Then the water pump went out. Well I was have issues with the starter so I decided to replace both at the same time. Also replaced the belt. So then I started up the car and ran it to refill the antifreeze after replacing the water pump and while I was running the car the battery light came on and I said charging system failure check the voltage on the battery and I was really low check the voltage coming out of the alternator and I was you know 13.6 but was not charging the battery. Did a whole bunch of checks I ended up replacing the alternator the PCM clean up the battery terminals on the battery the battery is holding charge but every time I start up the car and run it the battery drains and the alternator is not charging the battery then or now there's no voltage coming out of the alternator but there was before any help would be appreciated
 

Mad_Coachman

Active Member
1,293
412
83
Long Island
Buick Ownership
2002 LeSabre Limited 148k miles
How old is the battery? If you're having issues with your battery then why haven't you had the battery load tested at AutoZone, O'Reilly's??
 

2007LucerneCXL

Full Member
8,587
2,937
113
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
Try reposting under the Lacrosse forum and include year and engine to get the correct responses.
 
Get your turbo buick badge right here!
Protect your vehicle from code scanners
Top