• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Computer and electrical issues

sbj79

Buick Newbie
2
1
0
Buick Ownership
Buick
Hello all,

I have a 2013 Verano and recently my computer system has been on the fritz. I start my car with no issues but then my dash info area says I need to service pretty much everything on my car (Air Bags, Anti Theft system, Side Detection System, etc.). None of my gauges work either (gas, speedometer, rpms). The digital display for speed and gas do not work as well. My intellilnk and radio will also not come on. The car still drives fine and my lights and blinkers are on but I have no indication on my dash that they are on or working. The other issue is that sometimes it does this and sometimes it turns on with no issues at all. I called my local dealership and they told me they would have to charge me $100 for every service indicator that showed and I do not want to pay thousands of dollars if it's a simple corroded wire or something that simple. I have a friend that has a Chevy Cruze and his car had the same issues and it was a loose ground terminal connection. If anyone has any info on what this problem might be and could give me advice on how to proceed, I would greatly appreciate it. Thanks for reading and thanks in advance for any help you can give me.
 

MelsRegal

Full Member
4,134
545
113
Buick Ownership
Regal GS 2017
call another dealer, the comment of $100 for every service indicator makes no sense. If they told you diagnosis will be $100 per hour that would sound correct. Why isnt this issue covered by the 4 year 50K mile warranty, did you buy this car used from a private party?
 

sbj79

Buick Newbie
2
1
0
Buick Ownership
Buick
I bought it from a dealership but I'm over 50k miles so I'm not under warranty anymore.
 

Bill_S

Buick Newbie
9
0
0
Buick Ownership
Buick
Check the SMALL wire going from the negative clamp to ground. It may make its connection to ground thru a crimped connection to another wire. On the '88 LeSabre that was where I encountered the actual failure; the crimp couldn't maintain a connection between the wires within the crimp. The other small wire on the '88 that went to ground on the chassis was ok. Check 'em all!

I hope you have found the problem before this goes on the board.

Bill S.
______________________________
 

7D1977

New member
1
0
1
Buick Ownership
2013 Verano
Hello all,

I have a 2013 Verano and recently my computer system has been on the fritz. I start my car with no issues but then my dash info area says I need to service pretty much everything on my car (Air Bags, Anti Theft system, Side Detection System, etc.). None of my gauges work either (gas, speedometer, rpms). The digital display for speed and gas do not work as well. My intellilnk and radio will also not come on. The car still drives fine and my lights and blinkers are on but I have no indication on my dash that they are on or working. The other issue is that sometimes it does this and sometimes it turns on with no issues at all. I called my local dealership and they told me they would have to charge me $100 for every service indicator that showed and I do not want to pay thousands of dollars if it's a simple corroded wire or something that simple. I have a friend that has a Chevy Cruze and his car had the same issues and it was a loose ground terminal connection. If anyone has any info on what this problem might be and could give me advice on how to proceed, I would greatly appreciate it. Thanks for reading and thanks in advance for any help you can give me.
I am having same issue, did you ever find the cause of this issue, would much appreciate any direction to fix this issue. Thank you in advance
 

nlacomb

Buick Newbie
92
19
8
Buick Ownership
Buick
My wife's Verano had this issue. After much diagnostic work it ended up being the body control module. A roughly 300 dollar part at cost, and then it needs to be configured to each component in the car. I had a local mechanic/family friend do it for us at around 700 dollars with labor. I imagine it would be at least 3 times that at a dealer.
 

ken2017

Buick Newbie
1
0
1
Buick Ownership
Buick
I just had this happen in my 13 Verano April/19, although it would happen off and on when i took to local mechanic with nothing working his scan tool read faulty body control module. But when i went to dealership it was working normally guages,speedo ect with service side detection system on dic, turns out side detection modules and wiring harness were fried from corrosion. I do have a AAP aftermarket warranty but of course it does nt cover this $2000 repair, I have just left modules disconnected. Ken
 

Dlapierre

New member
1
0
1
Buick Ownership
Verano
My 2013 Buick Verano has been running very well, until today when I was listening to the radio without the engine on. Within 8-10 mins, the dash screen showed BATTERY SAVING MODE. I turned the car off, then the engine would not turn over at all. The was a quiet clicking but no engine. The lights still worked though
I tried to jump start with no joy.
I was researching online and there were suggestions for other car makes/models that just needed a sequence (ie break×5, emergency lights×2) in order to reset the computer system. HELP!
______________________________
 

G-936489

Hello all,

I have a 2013 Verano and recently my computer system has been on the fritz. I start my car with no issues but then my dash info area says I need to service pretty much everything on my car (Air Bags, Anti Theft system, Side Detection System, etc.). None of my gauges work either (gas, speedometer, rpms). The digital display for speed and gas do not work as well. My intellilnk and radio will also not come on. The car still drives fine and my lights and blinkers are on but I have no indication on my dash that they are on or working. The other issue is that sometimes it does this and sometimes it turns on with no issues at all. I called my local dealership and they told me they would have to charge me $100 for every service indicator that showed and I do not want to pay thousands of dollars if it's a simple corroded wire or something that simple. I have a friend that has a Chevy Cruze and his car had the same issues and it was a loose ground terminal connection. If anyone has any info on what this problem might be and could give me advice on how to proceed, I would greatly appreciate it. Thanks for reading and thanks in advance for any help you can give me.
Have you found a solution to this problem? because i have a friend whom is having the exact same issue and it is a 2014. It's keyless and sometimes she cant start the car via push button but it will allow her to do it remote start. The dash lights dim and brighten intermittently while showing a airbag, traction control, and tire pressure lights on the information console. The radio touch screen comes on but shuts off after 5 minutes, and the blinkers physically and somtimes they dont work but there is no indicator on the dash of the implied blinker direction.
 

Ron7742

New member
4
0
1
Buick Ownership
2013 verano
Hello all,

I have a 2013 Verano and recently my computer system has been on the fritz. I start my car with no issues but then my dash info area says I need to service pretty much everything on my car (Air Bags, Anti Theft system, Side Detection System, etc.). None of my gauges work either (gas, speedometer, rpms). The digital display for speed and gas do not work as well. My intellilnk and radio will also not come on. The car still drives fine and my lights and blinkers are on but I have no indication on my dash that they are on or working. The other issue is that sometimes it does this and sometimes it turns on with no issues at all. I called my local dealership and they told me they would have to charge me $100 for every service indicator that showed and I do not want to pay thousands of dollars if it's a simple corroded wire or something that simple. I have a friend that has a Chevy Cruze and his car had the same issues and it was a loose ground terminal connection. If anyone has any info on what this problem might be and could give me advice on how to proceed, I would greatly appreciate it. Thanks for reading and thanks in advance for any help you can give me.
Hello all,

I have a 2013 Verano and recently my computer system has been on the fritz. I start my car with no issues but then my dash info area says I need to service pretty much everything on my car (Air Bags, Anti Theft system, Side Detection System, etc.). None of my gauges work either (gas, speedometer, rpms). The digital display for speed and gas do not work as well. My intellilnk and radio will also not come on. The car still drives fine and my lights and blinkers are on but I have no indication on my dash that they are on or working. The other issue is that sometimes it does this and sometimes it turns on with no issues at all. I called my local dealership and they told me they would have to charge me $100 for every service indicator that showed and I do not want to pay thousands of dollars if it's a simple corroded wire or something that simple. I have a friend that has a Chevy Cruze and his car had the same issues and it was a loose ground terminal connection. If anyone has any info on what this problem might be and could give me advice on how to proceed, I would greatly appreciate it. Thanks for reading and thanks in advance for any help you can give me.
Wondering if you found the problem and what was it? Thank you!
 

Ron7742

New member
4
0
1
Buick Ownership
2013 verano
Have you found a solution to this problem? because i have a friend whom is having the exact same issue and it is a 2014. It's keyless and sometimes she cant start the car via push button but it will allow her to do it remote start. The dash lights dim and brighten intermittently while showing a airbag, traction control, and tire pressure lights on the information console. The radio touch screen comes on but shuts off after 5 minutes, and the blinkers physically and somtimes they dont work but there is no indicator on the dash of the implied blinker direction.
Did you find out what the problem was?
______________________________
 

G-877688

Hello all,

I have a 2013 Verano and recently my computer system has been on the fritz. I start my car with no issues but then my dash info area says I need to service pretty much everything on my car (Air Bags, Anti Theft system, Side Detection System, etc.). None of my gauges work either (gas, speedometer, rpms). The digital display for speed and gas do not work as well. My intellilnk and radio will also not come on. The car still drives fine and my lights and blinkers are on but I have no indication on my dash that they are on or working. The other issue is that sometimes it does this and sometimes it turns on with no issues at all. I called my local dealership and they told me they would have to charge me $100 for every service indicator that showed and I do not want to pay thousands of dollars if it's a simple corroded wire or something that simple. I have a friend that has a Chevy Cruze and his car had the same issues and it was a loose ground terminal connection. If anyone has any info on what this problem might be and could give me advice on how to proceed, I would greatly appreciate it. Thanks for reading and thanks in advance for any help you can give me.
Behind your rear bumper there's two modules for the detection disconnect them and your car is going to be fine
 
Turbo Buick Badge
Top