Envision 2.0 loss of power

Thread starter #1
6
6
3
Buick Ownership
2016 Buick Envision Premium II
Hello all,
Our 2016 Envision Premium II has just shy of 12K on it. We don't drive the car very much but lately i've noticed what seems to be a remarkable loss of power. When we bought the car it was quite snappy and had incredible low speed passing power. Lately it seems as if the turbo isn't even working because it feels like the power of a non-turbo engine. Last week I was traveling on the highway and stopped at a store. Car was shut off for a few minutes. Got back in, and got on the highway and the driveway was at the bottom of a slight hill. I was practially standing on it, and it actually felt like it was hesitating a little bit but had very poor acceleration. I have no warning lights and driving normally it does fine. We've tried running premium, and regular and don't see any difference in performance. It's getting about 21 mpg. Anyone else having any drivability issues like this? One would think if there was something going on with the turbo, it would set the check engine light.

Thanks,

John
 
Thread starter #3
6
6
3
Buick Ownership
2016 Buick Envision Premium II
I would get it into a dealership since it's only a 2016 and having these issues. There really shouldn't be an issue on a motor with 12,000 miles unless you neglected to change the oil yet.
Yeah going to talk to them on Friday. It's going in for it's third oil change so it's been done at the dealer when required. Between this and the front end wobble, I hope they can figure out what it is. This is the most expensive car I've ever bought, and the first one I've had problems with.
 

Skylarkin'

Sustaining Member
Sustaining Member
170
23
18
St. Louis, Missouri
Buick Ownership
2015 Buick Verano Turbo
Do you live in a dry and dusty location? While it seem premature, have you tried changing the engine air filter?
______________________________
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top