• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Faulty USB and Aux Port

bac0467

Buick Newbie
5
0
0
Buick Ownership
Buick
I have a 2010 Lacrosse and recently the USB port and Aux cord (which are located in the center console) both stopped responding/working. I have tried switching cords and even pressing the AUX button on the radio dash and the system will not recognize it. I thought it could be a blown fuse but I couldn't locate the exact fuse it seems to be mapped to.
I believed that if it was a blown fuse the light inside the center console would not be working as well?
Would this be an issue I could fix on my own or be better taking to Buick to fix?
 

tomtella

Full Member
30
4
8
Wolcott, CT
Buick Ownership
2010 LaCrosse CXL AWD
I also have a 2010 LaCrosse. My USB port seems to have a mind of its own, sometimes it works, sometimes it randomly drops out. The 8mm Aux Port, however, always works fine. I don't think the dealer is going to be much help, as the only recourse there is to replace the radio system.
 

bac0467

Buick Newbie
5
0
0
Buick Ownership
Buick
Yes I tried switching to a different cable for the iphone and then tried multiple aux cords.

- - - Updated - - -

Would I be able to get behind the ports and maybe see if the connections are loose?

Would they really have to replace the entire system in order to make the usb and aux connections function again?
______________________________
 

HMTJ6821

Full Member
473
8
18
Buick Ownership
Buick LaCrosse 2016
I believe that there is another "box" that handles the USB port. It is mounted above and behind the glove box. At the moment, I cannot remember the name of the box but there have been discussions on this site about it because the version installed in the 2010 (which I had until recently) was barely functional by today's standards.
 

bac0467

Buick Newbie
5
0
0
Buick Ownership
Buick
I believe that there is another "box" that handles the USB port. It is mounted above and behind the glove box. At the moment, I cannot remember the name of the box but there have been discussions on this site about it because the version installed in the 2010 (which I had until recently) was barely functional by today's standards.
By what you're describing, it sounds like the better chance to fix would be take it to Buick instead of digging around behind my glovebox? If it was a fuse or simple loose connections, I feel confident I could fix that, however digging around back there worries me a bit
 
2,414
8
38
Detroit, USA
Hi bac0467,

We're sorry to hear that you're experiencing this concern with the USB and Aux ports in your LaCrosse. I realize that you're looking for advice from other owners, however, I would be happy to provide an additional layer of assistance by reaching out to your preferred dealership to address this if you haven't contacted them already. If you'd like me to proceed, please send us a private message with your VIN, mileage, contact information and the name of your preferred dealer.

We look forward to hearing from you soon.

Best,

Ashley R.
Buick Customer Care

I have a 2010 Lacrosse and recently the USB port and Aux cord (which are located in the center console) both stopped responding/working. I have tried switching cords and even pressing the AUX button on the radio dash and the system will not recognize it. I thought it could be a blown fuse but I couldn't locate the exact fuse it seems to be mapped to.
I believed that if it was a blown fuse the light inside the center console would not be working as well?
Would this be an issue I could fix on my own or be better taking to Buick to fix?
 

tack000

Full Member
74
3
8
Toronto, Canada
Buick Ownership
LaCrosse 2012
I had issue where the USB port would not recognize any USB key. Took it in to dealer and they swapped the USB and AUX port. I think it's from all the USB key moving around and making bad connection. (Actually, if I remember correctly, the USB port blew up one of my 64GB memory key... I ended up getting replacement under warranty, but the copying music back to the key was a pain... (it was like making a mix cassette tapes from the 80's...)
______________________________
 

bac0467

Buick Newbie
5
0
0
Buick Ownership
Buick
Sorry for the late reply to the issue but finally sorted out what was going on. The dealership ordered in a new USB/Aux port part and replaced the entire thing, still no signal to it. After trying multiple avenues they determined that it was a malfunction with the radio communicating with the USB/Aux port receivers. In order to get the ports working again they would need to replace the entire radio (believe was quoted about $500 for this). Since the radio itself (AM,FM,XM) and CD player still work, it's a no go for now.
 

dbris

Full Member
163
5
18
Los Angeles
Buick Ownership
2011 Lacrosse CXS
I think you're looking at a mechanical problem, not a problem in the radio. The wires run from the aux input/USB board either direct to the radio or to the "Multimedia Player Interface Module" depending on which radio you have. The service manual isn't very clear on which is which, but the one with the interface module is probably the nav radio.
USB and Aux in, are two totally separate things and have nothing to do with each other except they share the same circuit board in the console, and the wire harness that runs to the radio or interface. So I would check the wire harness for cuts or pinched wires, and any connector related to that harness.
Few mechanics are electronics techs, and they tend to just replace parts until it works. And unfortunately most shops charge for all those parts whether or not they solve the problem.
 

douger

Full Member
341
7
18
Fort Wayne, Indiana
Buick Ownership
2012 Buick LaCrosse Touring
By what you're describing, it sounds like the better chance to fix would be take it to Buick instead of digging around behind my glovebox? If it was a fuse or simple loose connections, I feel confident I could fix that, however digging around back there worries me a bit
It your vehicle has the RPO code of USR, the usb port was installed at the factory, and has a separate harness running to the radio. If it does not have USR, it is a GM accessory, and has the box others are referring to.

Since our catalogs have RPO listings for all VINS, I haven't seen a SPID (service parts identification) label in years. The usual spots they put them is in the glove box, on the inside of the trunk lid, and, most likely on your vehicle on the spare tire cover.

If you can't find the label, PM me with the last eight digits of the VIN and I'll look it up for you.

Diagnosis? That's pretty hard to do. There aren't any fuses for the usb port. Depending on the system, it could be the port itself, the harness, or if yours is the accessory setup, the adapter box. It could even be in the radio.
 

G-836018

I have a 2018 regal GS. Once and a while (about twice a month)the intellilink will not recognize my phone or my ipod. Both are plugged in to USB ports. When this happens the whole intellilink system will randomly try to restart . I need a fix.
Please
 

heyeazy

Buick Newbie
2
0
1
Buick Ownership
Buick
I have a 2010 Buick Lacrosse cxs my usb wont recognizethe flash drive but if I drive for around 10 mins or so it recognizes it and plays but as soon as I turn car off it goes back in that sequence waiting till it reads, what's the issue?
 

stoopid

Full Member
1,670
223
63
Las Vegas, NV
Buick Ownership
2017 LaCrosse 1SL
I have a 2018 regal GS. Once and a while (about twice a month)the intellilink will not recognize my phone or my ipod. Both are plugged in to USB ports. When this happens the whole intellilink system will randomly try to restart . I need a fix.
Please
I average once or twice a month as well, par for the course with the current intellilink system. Usually I can just switch to radio and back to media/usb and it works, but occasionally it requires a full power cycle.
 

stoopid

Full Member
1,670
223
63
Las Vegas, NV
Buick Ownership
2017 LaCrosse 1SL
I have a 2010 Buick Lacrosse cxs my usb wont recognizethe flash drive but if I drive for around 10 mins or so it recognizes it and plays but as soon as I turn car off it goes back in that sequence waiting till it reads, what's the issue?
Are there a lot of music files on the USB? Are there a lot of layers/folders to the data on the usb drive? Only thing I can think of is it's slow to index them. If there's more than one usb port, any chance the olther things connected are the cause? [try with only the usb thumb drive inserted]

I had the most luck using the SD Card reader in my Regal (my LaCrosse doesn't have one). Near flawless music playback for the 2.5 years I had the Regal. if you have a SD Card reader maybe try using it for your music files instead?
______________________________
 
Top