• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Fuel Gauge Problem (I've done everything!!!)

ilir9b

Buick Newbie
17
1
3
Buick Ownership
Buick
Hey guys!
I have the ubiquitous fuel gauge problem in my 2003 Lesabre Custom. It goes up and down and there's no pattern - it doesn't matter if it's full or empty or half full.
I've changed the whole fuel pump a while ago. That didn't do anything. Just this week I pulled the cluster and changed the stepper motors. I thought this would finally do the trick but nothing happened. The same problem persists.
Does anyone have any other tips that can actually make this thing work?
Please help! This is driving me nuts.
Thank you, as always!
 

imidazol97

Top Dog
1,472
23
38
Haven't people reported the connections at a weatherproof connector for the electrical lines to the sender were the problem or a broken wire making and breaking contact along the run of wire.
 

ilir9b

Buick Newbie
17
1
3
Buick Ownership
Buick
Haven't people reported the connections at a weatherproof connector for the electrical lines to the sender were the problem or a broken wire making and breaking contact along the run of wire.

Thank you for the reply, I can't find that info anywhere. Or a way to check for it and let alone fix it.
Anyone else have any ideas or tips?
 

torres7

Full Member
115
7
18
Lincoln Nebraska
Buick Ownership
Buick RMW
When you say the whole fuel pump I assume you put in a new fuel level sending unit too, correct?
______________________________
 

ilir9b

Buick Newbie
17
1
3
Buick Ownership
Buick
When you say the whole fuel pump I assume you put in a new fuel level sending unit too, correct?

Yep! Sure did.
It wasn't the OEM or even the most expensive pump out there but I figured it would at the very least give me some different issues and not behave exactly like it did before with the old pump and sending unit.
 

W.Lasabre

New member
7
1
3
Buick Ownership
2004 Buick Lasabre
I'm going to try and ground off the harness at the pump and see if snything changes. Im having the same issue , classic lasabres
 
Pedal Commander
Top