Intermittent no sound from speakers, no turn signal sound, no chimes

dlahr

Buick Newbie
1
0
0
Buick Ownership
Buick
Thread starter #1
Ok, so just last month my Regal would start up with no sound from any speakers at all. I guess the turn signal noise is produced by the speakers as well as the door chimes etc. I get none of that. Head unit and NAV display are all still functional. After driving a ways and restarting the car the sound came back. That evening the same thing happened. Next week was fine. Then yesterday it happened again on the way to work. I believe there might be a correlation to rainy weather.

Where should I start to dig first? Are there any known water intrusion issues near the amp/bcm/???.
 

Notagto

Junior Member
23
1
3
Buick Ownership
Buick
#2
I had this problem that was soon followed by all sorts of strange warning lights (service transmission, service charging system, etc etc). Battery, alternator, starter all checked out good but battery wasnt holding a charge after a day or two. Replaced battery and have had no issues with stereo or other warnings for the last 2 weeks.
 

bigregal

Junior Member
21
1
3
Buick Ownership
16 Regal GS
#3
I had this happen to me with one of my other GM cars. My driver side would go out if it was cold outside. If it was warm, it would work fine. Replaced the speaker, didn't correct the issue - wasn't worth the hassle to me to look at wiring.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top