• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

No Air Conditioning at Higher Fan Speeds

Maccabee64

New member
11
1
3
Buick Ownership
2013 Verano
Hello Everyone!

I have a 2013 Verano and I am having an issue with my A/C. After turning the fan speed up past the second setting, the air is no longer cold. It is like there is no A/C at all at the higher levels.

Has anyone else had this issue?

I've read that people with similar issues on different makes have resolved this by replacing the blower motor resistor pack. Does that sound like it is worth a try?

Any other ideas?

Thanks in advance for your help!
 

MelsRegal

Full Member
2,998
315
83
Buick Ownership
Regal GS 2017
The air isn't cold or there is no air blowing? The resistor fix only covers the no air is blowing situation.
Have you checked the charge in the system with one of those R134 bottles with a gauge?
 

Maccabee64

New member
11
1
3
Buick Ownership
2013 Verano
The air does still blow it just isn't cold.

I have checked the charge of the system and it seems to be within the pressure range that it should be.
 
Top