No headlights is a drag!

TedKat13

New member
3
0
1
2005 Buick La Crosse
Have a 2005 Buick La Crosse. The low beams went out the other day. High beams work fine. Headlight Driver module has been replaced twice, without any improvement. When the highs are on, the lows still don't do anything.

Headlights have been replaced twice already. I see that there are two fuses on the line that says right headlight. Same for Left headlight. One fuse is 10A, the other is 15A.

Girlfriend is ragging on me about lights not working. Any suggestions, besides a new G/F would be appreciated. This is the 3rd time this has happened. What fixed it before isn't working this time. Thanks.
 

MelsRegal

Full Member
Staff member
5,085
782
113
Regal GS 2017
Are you using a test light or multimeter?
Do you have power at the fuse box?
Do you have power at the headlight socket?
Do you have a good ground at the headlight socket?
______________________________
 

TedKat13

New member
3
0
1
2005 Buick La Crosse
Are you using a test light or multimeter?
Do you have power at the fuse box?
Do you have power at the headlight socket?
Do you have a good ground at the headlight socket?
I just bought a new multimeter. My old one seems to have vanished in one of my moves. I've been avoiding pulling the headlights. I've done it twice already and, it's a pain in the rear.

This is the third time I've been through this with this car. Was this way when I brought the car back from the auction originally. The local Buick dealer has replaced the light switch in the dash. Now they're telling me that there is no safety recall on this car, when I have a copy of the stupid recall sitting right here on my desk.
 
Get your turbo buick badge right here!
Top