P2270 error

OlSmokie

New member
3
1
3
Buick Ownership
Regal
I'm getting a P2270 error (O2 sensor signal stuck lean on bank 1 sensor 2 to the control module ) on my 2011 Regal 2.4.
If I clear it, it will stay off for days, but then pop up again out of no where. The car still runs fine.
Funny thing is, twice now I've stopped for gas and as soon as I do, the light goes off. Could the tank not be getting vented?
Is it vented through the cap, or through the emission system?
Is there any other reason that removing the gas cap would fix the issue?
Thanks for your input.
 

OlSmokie

New member
3
1
3
Buick Ownership
Regal
I'm getting a P2270 error (O2 sensor signal stuck lean on bank 1 sensor 2 to the control module ) on my 2011 Regal 2.4.
If I clear it, it will stay off for days, but then pop up again out of no where. The car still runs fine.
Funny thing is, twice now I've stopped for gas and as soon as I do, the light goes off. Could the tank not be getting vented?
Is it vented through the cap, or through the emission system?
Is there any other reason that removing the gas cap would fix the issue?
Thanks for your input.
Update: I decided to run a can of fuel system cleaner through it and the light actually went off and has been off ever since. Must have been a dirty injector?
 

BoostedRegal2.0

Active member
274
119
43
Buick Ownership
2014 Regal 2.0 Turbo AWD Trifecta Tune
It does seem like that was the problem, if the CEL doesn't come back you'll know for sure.

I add fuel injector cleaner to the tank whenever I do an oil change. After receiving a large repair bill years ago to have 6 injectors replaced, I don't want to deal with that again.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top