Power steering and radio issues

Nico

New member
1
0
1
Verano
A few months after i purchased my 2015 verano I started to have issue's with the power steering and the radio. I thought it was a bad battery so i got it replaced .it stop for about a month but it started doing it again.for some weird reason when the radio would go blank the power steering would act up too.the screen on the radio would go black as if it turned off and at the same time the power steering would act funny.it would happen most of the time when I'm making a turn.if I was turning to the left the steering wheel would try to turn the opposite direction. I would have to hold on tight to the steering wheel while this happens just so the wheel wouldn't go the opposite direction.as that is happening the radio would turn off and then I would get warnings on my dash that say service StabiliTrak and service power steering. I also noticed sometimes when I put the windows up that would also cause the problem i don't know why though🤷🏽‍♂️.today while I was on my way to work it did it again but this time the ABS warning showed up on the dash and it stayed on for about 2 to 3 minutes.i took it to buick about 2 months ago to see if they can figure out what is the problem but they told me they found nothing.i even had the service manager ride with me but it wasn't doing it while he was in the car with me.it's to a point now I'm getting frustrated someone please help😫😫😫
 

2007LucerneCXL

Full Member
4,601
1,443
113
Illinois
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
Not sure what the dealer performed, charging system, battery, load test or just plugged into a scanner. Above what should be checked confirm the battery cables at the vehicle connections are clean and secure. Here's another post that has various reasons on what may cause some issues as in newer vehicles once the system drops below the required voltage things will start to intermittently happen.

Battery/starting issues
 

Mgoodacre

New member
8
0
1
2013 verano
There was a recall on something related to the power steering on my 2013 Buick Verano. I had it replaced with no charge from the dealer. I also had radio issues. My screen would go black or freeze, I couldn't change the channel or turn the volume up or down. My phone wasn't able to connect to my car either. I took it to the dealer they said it would be $1200 for a new radio, i told them to try an update, they did and it has worked fine ever since. That was about a year and a half ago.
 

oreocat

New member
2
0
1
2014 Verano
A few months after i purchased my 2015 verano I started to have issue's with the power steering and the radio. I thought it was a bad battery so i got it replaced .it stop for about a month but it started doing it again.for some weird reason when the radio would go blank the power steering would act up too.the screen on the radio would go black as if it turned off and at the same time the power steering would act funny.it would happen most of the time when I'm making a turn.if I was turning to the left the steering wheel would try to turn the opposite direction. I would have to hold on tight to the steering wheel while this happens just so the wheel wouldn't go the opposite direction.as that is happening the radio would turn off and then I would get warnings on my dash that say service StabiliTrak and service power steering. I also noticed sometimes when I put the windows up that would also cause the problem i don't know why though🤷🏽‍♂️.today while I was on my way to work it did it again but this time the ABS warning showed up on the dash and it stayed on for about 2 to 3 minutes.i took it to buick about 2 months ago to see if they can figure out what is the problem but they told me they found nothing.i even had the service manager ride with me but it wasn't doing it while he was in the car with me.it's to a point now I'm getting frustrated someone please help😫😫😫
I have a 2014 Verano with the same issues. Dealer is clueless as to the cause. Was there twice in 6 weeks, they acknowledged the issue, deleted several trouble codes (Didn't tell me what they were) and did firmware updates. However I know that it's related to the charging system because the dealer suggested that I leave the info screen on 'Battery Voltage' and I see that when the car "behaves" the voltage starts out a about 14.5 and then settles to a lower voltage depending on conditions. When the trouble starts, the voltage is up and down like a yo-yo and in the course of a couple of minutes of driving even after he initial recharge of the battery after start up the voltage will range between 12.8 up to 15.1 volts and will constantly fluctuate as long as I'm driving. When this happens, the screen will go dark esp. when stepping on he brake or making a turn and sometimes the 'service stabilitrak' message appears. Using my new Autel scanner shows over voltage faults for the brake control and ABS circuits. Ironically there are no codes for the charging system. I know that this issue is at least somewhat common to several GM cars and need to know if SOMEBODY has a clue as to what the heck is going on and how to correct it. I changed the current sensor on the neg. batt. cable since it was cheap, no effect. Wondering if a new BCM might help since it controls charging to a certain extent but don't want to pay the stealership big $ if it won't. Seems the system doesn't stay "in mode" since there are 5 or 6 charging modes that hold the voltage in a certain range in each one. As a former automotive electrical tech, I can say that your issue and mine is DEFINITELY a charging system issue and your ABS and Stabilitrak (Which are interconnected) and your radio are not defective since these electronics are voltage sensitive and do NOT want out-of-range voltage to operate. Sorry about the long-winded replay but this IS annoying as hell.
______________________________
 
Last edited:

oreocat

New member
2
0
1
2014 Verano
oreocat, is your car still using its OEM battery? That, or the voltage regulator might need to be replaced.
Battery was replaced by me about 10 months before this started since the old batt. was getting 'tired'-slower cranking on cold mornings. Dealer tested battery both times and said it was good. VR may be bad but BCM also controls gen output. I would think bad reg would cause either little to no charging or output voltage well over 15 volts. The symptoms I described above generally don't occur when the AC or lights are on which points me to the BCM but I need to know for sure.
 
Turbo Buick Badge
Top