Radio settings changed to Cadillac after blower motor resistor replacement

Thread starter #1
1
0
1
Buick Ownership
2010 Buick LaCrosse CXS
I just changed my heat a/c blower motor and the resistor (on 11/23/18) and now when I start my car the Cadillac emblem comes up on the radio screen and the screen colors are dark blue and red. It's also intermittent. If the Cadillac emblem shows it will switch to GM and then to Buick also the screen color does not change every time it shows Cadillac either. I have not yet disconnected the battery, I planned on it after work today. Is there a way to fix this without taking it to a shop?
 

L J

Member
71
6
8
Buick Ownership
Regal TourX
If you have not disconnected battery yet, I would disconect for 5 minutes or so and see if that fixes problem.Of course you will lose all your presets on radio and any customization settings.
LJ
 

Rich B.

Active member
251
40
28
Minot, ME
Buick Ownership
2016 LaCrosse & 2013 Boss 302 Mustang
Roger that on battery disconnect. Also unless exact replacement plug and play wires possibly cross-connected. Also possibly with unfiltered motor running creating distortion or interference with screen. I mean look at reception of digital free air TV during a thunder storm🤔
 

Blu05

Junior Member
88
8
8
Michigan
Buick Ownership
2005 Buick Lacrosse
That's a strange thing for the radio to display "cadillac" after replacing your heat/A/C resistor. I actually never heard of that happening before. Could it be BCM related? Or maybe something glitched after the repairs were made?
______________________________
 
957
275
63
Illinois
Buick Ownership
2007 Lucerne CXL. and 1995 Lesabre currently, past 1973 Riviera, 1968 Riviera
Assuming you didn't disconnect the battery while doing the repair it may have thrown a glitch. When disconnecting the battery a minimum of 10 minutes is needed to clear things out, timed auto shut down, and possibly pulling the radio fuse. Can't say this will fix the problem, but it's best guess.
 
48
9
8
Pittsburgh Pa
Buick Ownership
14 Lacrosse Premium AWD 15 Enclave Premium
You radio defaulted to a caddy program. I had a radio replaced in a Equinox i owned and when they loaded the program it came up cadillac. I had to return it to the dealer so they could reprogram to a chevy program. It is possible that the radio in that car was replaced with a caddy radio and it defaulted back. With the equinox XM had it as a caddy.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top