• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Range Technology Device caused Engine error/Reduced engine power

greenne

Active member
156
68
28
Albany, NY
Buick Ownership
2019 Regal TourX
All,

Like many I absolutely hate the Auto Stop start on the TourX. Like many I'm baffled GM didn't offer a switch to turn it off. Anyway after reading reviews on Amazon and also others here--I spend $180 for the range technology OBD device. (You can follow it here in this thread: Disable Automatic Stop/Start)

I installed before my drive home from work today. Plugged into OBD port, started car, went to drive home. First 5min was great. There was rush hour traffic..so it was stop light to stoplight delays. No problem Car didn't shut off. Car responded like it should.

About 5min into my drive, there in a long freeway entrance ramp. I was accelerating about 1/2 throttle get into 40-50mph heavy traffic when the car suddenly lost power and a message came on screen "reduced engine power". It wasn't quite limp mode and it didn't stall..but noticeable and I was not accelerating as fast as I should be. 5sec later engine went back to normal--normal power and message cleared.

10min later on i90...traffic cleared a bit so I had cruise control set at 60mph. Slight rolling hill but very much a smooth cruise..it happened again. Car lost power and I had to nearly floor it to maintain 60mph. "Reduced engine power" on DIC.

I pulled over. Removed Range technology device and drove rest of way home(about 30min more) with no issues at all. Last 5min was stop light...without device ASS functioned as normal. At no time did I get a CEL..after device was removed car seemed normal with no issues.

Obviously, I will be returning the device to Amazon. I know it has worked for some people with no issues--but just wanted to let you know my car did not like it at all and caused major issues. It could have been a major safety concern if it happened at the wrong time. I'll just have to deal with the stop/start old school way and throw the shifter into manual at stoplights.

Just FYI.
 

greenne

Active member
156
68
28
Albany, NY
Buick Ownership
2019 Regal TourX
No letter.

I suppose it *could* be a coincidence but today was the first time I plugged the device in and error happened 5-10min after. This was first time I have seen that error. A possibility, yes..but I think it much more likely the device is causing the car to think there is some sort of fault and the ECM reduces power as a safety measure.
 

Wlepse

Well-known member
564
263
63
NNJ
Buick Ownership
2018 Regal TourX Essence
Could be...just figured I would mention the other known issue with some TourX's.
______________________________
 

greenne

Active member
156
68
28
Albany, NY
Buick Ownership
2019 Regal TourX
Well here's a kicker. I just did some poking around on Range Technology's website. The devices you buy off ebay, amazon etc. are NOT real updated Range devices. They are knockoffs. Or more appropriately they maybe old versions someone is reselling, old software, returned items, refurbished items. Range Technology flat out says they DO NOT have any authorized distributers on Amazon. So it is very likely I was sent a defective device.

I will be dropping off for Amazon return tomorrow..so I think I am OK refund wise.(Amazon has good return policy).

But buyer BEWARE. I contacted Range Technology for support in choosing the correct device and see if they can assist with putting my mind at ease perhaps. Thinking it may have been a bad/old/defective unit.

Obviously I'm a little nervous now putting something on a brand NEW car that reacted poorly last go around.
 

saab93driver

Active member
237
125
43
Buick Ownership
2019 TourX
I’ve been using the Range device for 2 weeks and several hundred miles. So far, so good. I did buy it from Range directly. Prior to that I had the Start-stop that plugged in under the hood, it worked great but I didn't like how it interfered with the remote start.
 

Kybuck83

Member
77
72
18
Orange County, CA
Buick Ownership
2019 Regal TourX Essence
I also bought the Range Technologies device off Amazon, and noted the lack of potential warranty support in the other start/stop discussion. But Amazon ships to California and offers two day shipping with Prime, so I was willing to take the risk. Most of the firmware discussion on the Range Technology website seemed specific to the AFM disabler device and not start/stop disabler.

That being said, I had the "reduced power" error once in the two weeks I've had it. In my case, I noticed the defeat didn't work and the engine turned off at a red light. This was after the car had only been off for a few minutes before being restarted. I unplugged and reinserted the device and the error showed up shortly after. I then unplugged it and it drove normally (with start/stop) the rest of the trip. I reinserted again before starting the car for my next trip, and it's worked flawlessly since then.

If someone with an "official" version can verify the firmware revision, that could be helpful to determine if the Amazon ones are actually outdated. I couldn't find a latest firmware listed on their website. My packaging doesn't have the sticker (that I could find), but counting the blinks it looks like I have version 8.6.


I'm guessing the reduced power has something to do with whatever command/signal is being sent over OBD2 to result in defeating the start/stop. I'll report back if there are any further issues.
 

saab93driver

Active member
237
125
43
Buick Ownership
2019 TourX
No firmware listed on my box as described by Range website. Just a decal with the UPC bar code 860001618662 and a blue dot and it says Range Start/Stop Disabler - BLUE. I covered the LEDs with tape so I haven't checked the blink sequence for firmware revision.
______________________________
 

Uniqez

Active member
186
47
28
Buick Ownership
2018 Regal TourX Essence
Ok, so I've been using device for a bit without any issues (purchased direct from RT). Today, on the way back from the airport I've got the message. Reduced power....Something is definitely going on here.
I suppose software version is on the sticker on the actual device. Mine says RA 005.
Will be sending email to RT tonight.
 

saab93driver

Active member
237
125
43
Buick Ownership
2019 TourX
Knock on fake wood but mine is still working flawlessly after 2 weeks and several hundred miles. I’m never really lucky so I hope it’s not an anomaly.
 

FavaBean

Active member
306
184
43
DE
Buick Ownership
2018 Regal TourX Essence
Would the car store a code for the reduced power message? Then bring it to AutoZone to see if their OBD diagnostic tool picks up the code?
 

Uniqez

Active member
186
47
28
Buick Ownership
2018 Regal TourX Essence
Would the car store a code for the reduced power message? Then bring it to AutoZone to see if their OBD diagnostic tool picks up the code?
It would be good to know. My colleague has odb diagnostic scanner, will have to check this.
I was thinking what have changed:
Car was seating at the airport for 3 days
Module was unplugged
Ambient temperature dropped
Why it started doing this....
______________________________
 

Kybuck83

Member
77
72
18
Orange County, CA
Buick Ownership
2019 Regal TourX Essence
I suppose software version is on the sticker on the actual device. Mine says RA 005.
Will be sending email to RT tonight.
RA005 is just the model number, you'll have to count the blinks to get the firmware revision.
It would be good to know. My colleague has odb diagnostic scanner, will have to check this.
I was thinking what have changed:
Car was seating at the airport for 3 days
Module was unplugged
Ambient temperature dropped
Why it started doing this....
I just plugged in my ODB2 and no fault codes were stored, but it's been almost two weeks since it gave me the error.

For yours, was the start/stop disabler plugged back in before or after the car was started? My error occurred after unplugging and reinserting while the car was running (and not in park). Wonder if it's happier being installed when the car isn't running for some sort of startup handshake.
 

Uniqez

Active member
186
47
28
Buick Ownership
2018 Regal TourX Essence
RA005 is just the model number, you'll have to count the blinks to get the firmware revision.

I just plugged in my ODB2 and no fault codes were stored, but it's been almost two weeks since it gave me the error.

For yours, was the start/stop disabler plugged back in before or after the car was started? My error occurred after unplugging and reinserting while the car was running (and not in park). Wonder if it's happier being installed when the car isn't running for some sort of startup handshake.
The car was off when I plugged it back in, but not sure,if I have waited for lights to finish blinking.
I'll check that again tomorrow.
 

greenne

Active member
156
68
28
Albany, NY
Buick Ownership
2019 Regal TourX
Since it didn't throw a CEL...I'd be surprised if there are any codes.

Mine was plugged in before startup. Granted it was the first time I used it.

Sorry to jinx this for everyone. My bad.
 

Uniqez

Active member
186
47
28
Buick Ownership
2018 Regal TourX Essence
Quick update here. Plugged it in this morning. Waited until it did initialization, started the car- no warnings, everything is back to normal.
______________________________
 

landsharkmz3

Active member
147
77
28
Well here's a kicker. I just did some poking around on Range Technology's website. The devices you buy off ebay, amazon etc. are NOT real updated Range devices. They are knockoffs. Or more appropriately they maybe old versions someone is reselling, old software, returned items, refurbished items. Range Technology flat out says they DO NOT have any authorized distributers on Amazon. So it is very likely I was sent a defective device.

I will be dropping off for Amazon return tomorrow..so I think I am OK refund wise.(Amazon has good return policy).

But buyer BEWARE. I contacted Range Technology for support in choosing the correct device and see if they can assist with putting my mind at ease perhaps. Thinking it may have been a bad/old/defective unit.

Obviously I'm a little nervous now putting something on a brand NEW car that reacted poorly last go around.
Report it as a fraufulent part on Amazon. Amazon is full of fakes, and relys on customers to help weed out fraudulent parts.
 

L J

Well-known member
1,514
435
83
Buick Ownership
Regal TourX
I would have thought people were smart enough to realize plugging something into OBD port all the time is not a good idea. Changing the functionallity of your vehicle through diagnostic port can void your warranty, and leaves your car unprotected from viruses and or hacking.
 

greenne

Active member
156
68
28
Albany, NY
Buick Ownership
2019 Regal TourX
I would have thought people were smart enough to realize plugging something into OBD port all the time is not a good idea. Changing the functionallity of your vehicle through diagnostic port can void your warranty, and leaves your car unprotected from viruses and or hacking.
Obviously you've never heard of the Magnuson-Moss warranty act...
 
Pedal Commander
Top