• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2008 LaCrosse" isn't going to indicate to anybody that you need help. However, "Need help with my 2008 LaCrosse" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

screen froze up then went blank

mike12verano

Full Member
132
2
0
Eaton Rapids Mi
Buick Ownership
Buick Verano
I got in the car last night and the radio was on an AM station. I started the car and hit the source button to listen to something else. no reaction, I hit a different station button, same results. hit the power button, NOTHING. shut off the car, started it back up and had a blank screen and no radio no intellilink. drove the car home. got up the next morning and everything was working again.

not sure i can do anything right now since it's working again. hope this does not come back again.
 

miou

Full Member
69
1
0
Buick Ownership
Buick Verano
Haven't had anything like that happen myself, sorry to hear.

There does appear to be 100% reproduceable glitch when dialing through stations via the steering wheel that switch between XM and FM. It's like the pointer for where you are in a menu gets dropped and the system forgets where you are.
 
2,414
9
38
Detroit, USA
I would recommend keeping an eye on this. If it happens again, I would recommend contacting your local dealer. Please feel free to keep me posted. Thank you.

Tricia, Buick Customer Service.
______________________________
 

brian1121

Buick Newbie
3
0
0
Buick Ownership
Buick
same thing happen to me today!! after I start the car today, the screen froze up right after the buick logo pops out, it just stay like that, I restart again, same thing. I only have this car for 3 days!!! I'm taking to the dealer tmr !!
 

mike12verano

Full Member
132
2
0
Eaton Rapids Mi
Buick Ownership
Buick Verano
same thing happen to me today!! after I start the car today, the screen froze up right after the buick logo pops out, it just stay like that, I restart again, same thing. I only have this car for 3 days!!! I'm taking to the dealer tmr !!

Please let me know what they find. I'm starting to have a different problem with the audio. it is changing sources ramdomly
 

Veranouser

New member
1
0
1
Buick Ownership
Verano 2016
I am extremely disappointed with this car. This is the 4th time that I take it to the dealer to have it repaired due to the radio freezing and the screen turning black. I am not able to lower volume, change the station, etc. I have to pull over, turn off the car and turn it back on to try and get it to reboot. The dealership folks tell me they are unable to find what the issue is
 

KevinJ

Contributing Member
333
55
28
Ohio
Buick Ownership
2013 Verano Premium (2.0T, AT)
Luckily, my 2013 with 35,000 mile has not had any electrical problems. Yet...
However, I fully expect it to as mileage and time passes.
Heck, most of the time I'm surprised it even starts. No, I'm not kidding...

With all of the really unnecessary electronic gadgetry on these cars, should we be surprised.
Do we really need backup cameras, motion sensors, lane sensors, built in navigation, a screen for the radio, bluetooth, USB, satellite monitoring and tracking(OnStar), etc? Not to mention the advanced engine and drive train computers and sensors.

Whatever happened to the KISS principal?
Complexity always adds points of failure.

For the record... I've been a software engineer and programmer for over 30 years.
I actually wrote my first computer program 40 years go.
So I'm not just another luddite complaining about technology.
I've just been around computers and technology long enough to know that both software and hardware are NEVER and WILL NEVER be foolproof.
 
Last edited:

JGB

New member
2
0
1
Buick Ownership
2015 encore awd
I got in the car last night and the radio was on an AM station. I started the car and hit the source button to listen to something else. no reaction, I hit a different station button, same results. hit the power button, NOTHING. shut off the car, started it back up and had a blank screen and no radio no intellilink. drove the car home. got up the next morning and everything was working again.

not sure i can do anything right now since it's working again. hope this does not come back again.
My
______________________________
 

JGB

New member
2
0
1
Buick Ownership
2015 encore awd
I got in the car last night and the radio was on an AM station. I started the car and hit the source button to listen to something else. no reaction, I hit a different station button, same results. hit the power button, NOTHING. shut off the car, started it back up and had a blank screen and no radio no intellilink. drove the car home. got up the next morning and everything was working again.

not sure i can do anything right now since it's working again. hope this does not come back again.
My encore went blank. I had a software update, but it still continued to freeze.
Sometimes it would get green lines up and down the screen.
I find it's when the temperature is 29 degrees +.
The screen seems to overheat in the sun.
Love this car
 

13VeranoFLA

New member
1
0
1
Buick Ownership
2013 Buick Verano
2013 Buick Verano here. Went to the store, radio/NAV screen was working fine. Came back out and nothing. I've changed all the fuses, disconnected the battery to reset computer and had Buick customer service walk me through a "reboot" of the infotainment system. I've waited until the next morning hoping and nothing. It's been 3 days now. I have a black screen and the radio controls on the dash and steering wheel are not working. Next I guess is to pull the trim and check for a faulty connection. There is no power to the radio.
 

Onlygm

New member
3
0
1
Buick Ownership
2013 buick verano
2013 Buick Verano here. Went to the store, radio/NAV screen was working fine. Came back out and nothing. I've changed all the fuses, disconnected the battery to reset computer and had Buick customer service walk me through a "reboot" of the infotainment system. I've waited until the next morning hoping and nothing. It's been 3 days now. I have a black screen and the radio controls on the dash and steering wheel are not working. Next I guess is to pull the trim and check for a faulty connection. There is no power to the radio.
My 2013 verano started out screen going black. 2 weeks later engine would shut off and turn right back on by itself. Had bcm changed at dealer and that wasn't the problem. Next day I went to fuse box under hood to check relays and I found that my positive cable at the fuse block was getting extremely hot. So I took it back to dealer and pointed that out to them and had them do a complete elect. Diagnosis. Turns out I was losing voltage at that connection. Had them replace positive and negative cables as well as the whole fuse block that's on top of the battery. It's been 2 weeks and I have had no more problems. Hope this helps
 

Onlygm

New member
3
0
1
Buick Ownership
2013 buick verano
My 2013 verano started out screen going black. 2 weeks later engine would shut off and turn right back on by itself. Had bcm changed at dealer and that wasn't the problem. Next day I went to fuse box under hood to check relays and I found that my positive cable at the fuse block was getting extremely hot. So I took it back to dealer and pointed that out to them and had them do a complete elect. Diagnosis. Turns out I was losing voltage at that connection. Had them replace positive and negative cables as well as the whole fuse block that's on top of the battery. It's been 2 weeks and I have had no more problems. Hope this helps
______________________________
 
Pedal Commander
Top