She's sick....

rodslinger

Full Member
159
15
18
Atlanta, GA
Buick Ownership
14 Regal GS
Well this is a new one. I suspect the HPFP went out. 2014 AWD GS. It acted like a weak battery as the engine was turning over slowly. About a mile down the road it started to misfire slightly under load. Immediately turned around and came home. Tried to restart and it again started slowly like a weak battery. It would idle but misfire badly if you try accelerate or move it more than about 10mph. I did a short search and didn't see anything really related. Pulled out the scanner and had random misfire counts on all cylinders and fuel pressure errors.

Voltage at idle and while starting is good. Put a new battery in it anyway just to rule it out as I still had the original one in there. No improvement. Guessing the HPFP is dead or dying and causing a LOT of drag when trying to start the car. Waiting to hear from the dealer. Luckly the B2B warranty is still good until April of next year.
 

Attachments

rodslinger

Full Member
159
15
18
Atlanta, GA
Buick Ownership
14 Regal GS
I had wondered about that but it still idles butter smooth and no rattles at idle or above idle.

Service writer sent me an email about an hour ago and said it has a bad coil pack. They ordered one and it will be in tomorrow. I've had bad coil packs before and this didn't feel anything like an ignition miss.

If you've ever driven a car with a clogged fuel filter or bad fuel pump it is exactly what it feels like. Not a dead miss but a general hesitation, buck, backfire, bad stumbling kind of thing. Just no power at all.

I remember when this thing dropped a cylinder. It would still get up and go on three cylinders once it got some boost. Right now it can't rev high enough or load up enough to build boost.

I'm betting they pulled it around the building and felt the miss. Pulled codes for the misfire and ordered a coil pack. They will troubleshoot it tomorrow when they realize the coil didn't fix it. Typical dealer thoroughness.
 

rodslinger

Full Member
159
15
18
Atlanta, GA
Buick Ownership
14 Regal GS
Didn't hear from the dealer today. I haven't tried calling either. They either got busy, the part didn't show or the found another issue. I'll call Monday if I don't hear back by tomorrow afternoon.
 

rodslinger

Full Member
159
15
18
Atlanta, GA
Buick Ownership
14 Regal GS
Did this happen on a cold start with no warning? Keep us in the loop.
Pretty much no warning at all. The slow start has been going on a few weeks. And not really THAT slow but it maybe turns over just slightly slower than normal. The car is only driven once or twice a week so I always chalk it up to it just sitting there.

Tuesday morning was normal and drove my kid to school. Came out two minutes later and it took three tries to start. Misfires started about a mile down the road after that.
______________________________
 

rodslinger

Full Member
159
15
18
Atlanta, GA
Buick Ownership
14 Regal GS
Dealership still has the car. I've not gotten all the info as to what was done but the holdup is apparently the instrument cluster. I've had the instrument cluster rattle since I bought it and told them don't give it back until it is fixed. I showed them how the black trim ring around the cluster is loose and a video of if rattling over broken pavement.

They sent an email that basically indicating the trim ring is a bad design and they are waiting on some 2mm foam tape they wanted to place between the trim piece and instrument cluster lense to keep it from moving and hold tension on the mounting tabs.

Crossing my fingers.
 

rodslinger

Full Member
159
15
18
Atlanta, GA
Buick Ownership
14 Regal GS
All fixed. I would first like to claim continued good service from Hardy GMC/Buick in Dallas, GA. They have always fixed it right the first time and sometimes even fix things I didn't even bring it in for. If you are within 100 miles of this place, go there for service.

Work order showed coil pack on cyl #4. Surprised me. It really felt like a lean misfire. Runs great now. Dash rattle is gone finally also. They went out of their way to make sure the cluster is snug and the trim ring is tight.

They also noticed a faint squeak in the blower motor that I'm not sure I ever heard and replaced it while there. I appreciate it when the dealer is a bit more proactive and takes care of things I may not have noticed. Especially if they do it before my warranty expires which probably saved be money down the road.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top