Sputtering and Stuttering at Idle

StiltsRU

Full Member
126
0
0
Northern Virginia
Buick Ownership
2012 Regal GS
So I know I've read on here that some people are having issues with the car sputtering at lights, like it's going to stall. I didn't really have this problem until about 2 weeks ago (12k miles), when I could really notice it.

I just thought 'whatever' until the car stalled out and died at a light this past weekend. Foot off the clutch, out of gear, etc. Started back up just fine, but definitely a little unnerving. Since then, the sputtering seems to be getting worse, like the car is struggling not to stall when stopped.

My questions are: Has anyone talked to the dealer about this? Did they do anything about it? Of course I can't guarantee it will do it when I take it in.

Thanks in advance, and sorry for the dupe post.
 

stive403

Full Member
126
0
0
Wauwatosa, WI
Buick Ownership
2012 Regal GS
I've had it stumble a couple times at lights now. a little unnerving, but hasn't stalled. Let me know if you figure something out.
 

cozbyrt

6.0L LS2 Member
686
1
18
Texas
Buick Ownership
2011 Buick Regal T-05
My didn't stall but did have the rough idle a few times. Dealer couldn't duplicate the problem.
 

JJhummus

Full Member
26
0
0
Beavercreek, Ohio
Buick Ownership
Buick, Pontiac
I get it in my GS. pull up to a light and all of a sudden the idle drops and it starts loping my 6.0l...
______________________________
 

Taxman1985

Full Member
45
0
0
York, Nebraska
Buick Ownership
Buick Regal GS (CRT)
Do any of you guys have aftermarket oiled filters, like the K&N drop in?

I know with my cobalt that had an Injen CAI, the throttle body would get coated in oil occasionally and that would cause a stalling or rough idle.

All we had to do to get rid of that was pull off the CAI, spray some throttle body cleaner on a rag, and wipe out the throttle body. Some people had problems with their mass air flow sensors too for the same reason.

I don't know this engine too well, but if that is a possible problem that you guys are having, it is possibly a very cheap and easy fix.
 

bennyblaze

Full Member
412
4
18
Ypsilanti, Michigan
Buick Ownership
2012 Buick Regal GS
Do any of you guys have aftermarket oiled filters, like the K&N drop in?

I know with my cobalt that had an Injen CAI, the throttle body would get coated in oil occasionally and that would cause a stalling or rough idle.

All we had to do to get rid of that was pull off the CAI, spray some throttle body cleaner on a rag, and wipe out the throttle body. Some people had problems with their mass air flow sensors too for the same reason.

I don't know this engine too well, but if that is a possible problem that you guys are having, it is possibly a very cheap and easy fix.

Or an aftermarket BOV? My buddy had one in his Subaru, and he had the exact same issues, especially after the BOV releases. He said the reason the car stalls is the car's ECU expects a proper air to fuel mixture when the air is released. Because the mixture has more fuel, often this leads to some bad bogging (or even throwing a CEL), which may have caused the stalling. He took it out and put the OEM BOV back in. Then the problem went away. Find out he had to reprogram his tune for the aftermarket BOV. Don't know if this is related, but it may be worth looking into.

I hope this info helps. Good Luck!
 
Last edited:

StiltsRU

Full Member
126
0
0
Northern Virginia
Buick Ownership
2012 Regal GS
Or an aftermarket BOV? My buddy had one in his Subaru, and he had the exact same issues, especially after the BOV releases. He said the reason the car stalls is the car's ECU expects a proper air to fuel mixture when the air is released. Because the mixture has more fuel, often this leads to some bad bogging (or even throwing a CEL), which may have caused the stalling. He took it out and put the OEM BOV back in. Then the problem went away. Find out he had to reprogram his tune for the aftermarket BOV. Don't know if this is related, but it may be worth looking into.

I hope this info helps. Good Luck!

Thanks for the info. I have both the k&n and the bov. I think the k&n might be more of the culprit because the remapped tune should handle the air/fuel (or so I was told).

I'm going to try the throttle body cleaner.
 

NewTekBuzz

Full Member
438
0
0
Flint Area
Buick Ownership
Buick Regal T07
Mine is all stock, dealer could not duplicate! no rime or reason. one time it was so bad I thought it was going to pull me into the intersection!
good luck and keep us posted
btw... mine is not a GS and is an automatic.
______________________________
 

RevJohnnyVegas

Full Member
248
1
0
DFW, Texas
Buick Ownership
2012 Buick Regal GS
I've had this happen a couple of different times to me. Every time it has happened when I've first gotten in the car and its been cold (by DFW standards), so I've largely just chalked it up to the car being like its owner and hating cold weather.
 

StiltsRU

Full Member
126
0
0
Northern Virginia
Buick Ownership
2012 Regal GS
I've had this happen a couple of different times to me. Every time it has happened when I've first gotten in the car and its been cold (by DFW standards), so I've largely just chalked it up to the car being like its owner and hating cold weather.

I agree with you. The day it stalled, it was super cold, and I didn't give the car the warm-up time I usually do (so I chalked it up to the weather).

But even on the weird warm days we had this week, it was still going on.
 

MikeC725

Full Member
1,029
30
48
Northville, MI
Buick Ownership
2014 Regal GS AWD
I've had the rough idle also. But it seems to happen more when I put in mid grade gas (89 octane). I normally run 93. It doesn't matter the temp outside or the temp of the car. It did it when it was 70*F outside and 10*F outside. It's just very random.
 

stive403

Full Member
126
0
0
Wauwatosa, WI
Buick Ownership
2012 Regal GS
no bov or filter mods here. but I agree, it typically happens when it's cold and the car is till somewhat cold.
______________________________
 

RevJohnnyVegas

Full Member
248
1
0
DFW, Texas
Buick Ownership
2012 Buick Regal GS
I've had the rough idle also. But it seems to happen more when I put in mid grade gas (89 octane). I normally run 93. It doesn't matter the temp outside or the temp of the car. It did it when it was 70*F outside and 10*F outside. It's just very random.

I've never had anything but 93 octane in mine and I noticed this behaviour a couple of times before I did any mods to it.
 

CanAmChris

Full Member
112
2
0
Austin, Tx
Buick Ownership
Buick Regal GS
Mine does the same thing, usually after the car has been driven at speed for any distance, engine hot or cold. When I come to a stop it will stumble and buck for a second or 2 and then its fine. My GS is bone stock sans a K&N drop in air filter. But it did the same thing with the stock paper filter as well. I haven't taken mine into the dealer yet.
 

Ct'sBuickGuy

Full Member
154
1
0
CT | 860
Buick Ownership
2012 Regal GS
Mine does it when cold and coming to a stop light, I cant make it happen when I want. I work at a dealer and everytime i grab a tech to go for a ride it doesn't do it.
______________________________
 

LouB2B

Full Member
120
0
16
Mentor, OH
Buick Ownership
2012 Buick Regal GS
Add me to the list...all stock (though tinted widows). 17K miles and has happened several times when stopped at a light and recovered on its own. Dealer serviced since new.
 

MountainGoat

Full Member
103
0
16
Buick Ownership
2012 Buick GS
GS, 4600 miles, bone stock. Mine has stumbled maybe three times -- always while stopped and idlign, usually when it has been cold. I think C&D or some other car mag mentioned this in their review as well. Happened to them once and never again. Clearly seems like the computer is getting bad input or just the right conditions trigger it.

Anyone with a tune have the stumble issue?

Clearly there's a problem. Too many people reporting this issue for it to be a coincidence.
 
Get your turbo buick badge right here!
Top