Starting issue/stalling/choking and acceleration hesitations Regal 2011

frenchmanfl

Junior Member
22
0
0
Buick Ownership
Buick
Hi everyone,

I have a Regal 2011 with only 41K miles. I bought her with 36K miles and have only had her for 6 months.

Over the last couple of weeks she has developed an issue that I know needs attention but I am tight for cash (drive Uber to supplement), so have managed to get by without having to take her in. I thought that I might have bought gas from some shady station here in Miami and that the issue might go away but it isn't. It doesn't seem as bad as two weeks ago but is still there.

Started with just stalling in mid drive, hesitations during acceleration, choking slightly at idle and now when filling her up, it takes a few minutes before she will start (feathering the throttle until she kicks back in). Strangely the starter keeps turning even after I have returned the key position back to not engaged (as though it is stuck). The rough starts have also happened after short stops and a couple of occasions after sitting overnight.

I have done a bunch of research on line and have, of course, narrowed it down to the fuel line/supply or possible spark plugs, all issues that should not be causing me problems with only 41K miles, right?

The issue is that sometimes, she drives perfectly well. I will start her up without issue, will drive an entire day (also do field sales) and no issues whatsoever and then, as though the circulation has hit a dirty path in the line, things go bad, she chokes up (I throw her into neutral and hit the gas to keep the revs up and then throw her into drive - not pleasant with a passenger).

I am wondering if any of you might know of a problem with the 2011 Regal that would cause a car to have such a problem at only 41k miles.

PS The check engine warning has come on and then gone off throughout this time. Tonight it is back on. Also when I have tried starting her up and she doesn't, I see a warning about Stabilitrak?

Any ideas? I need to do this through an independent mechanic and would like to be able to buy the part online to save money. Any advice or ideas would be deeply appreciated.

Thank you very much, in advance.
 

HotZ28

Full Member
6,456
119
63
Buick Ownership
1996 Roadmaster Limited Collectors Edition 58k - 1996 PAU
PS The check engine warning has come on and then gone off throughout this time. Tonight it is back on. Also when I have tried starting her up and she doesn't, I see a warning about Stabilitrak?
The pending code(s), history code(s) and current code(s) should be available to view with an OBDII scanner. You need to find someone who is capable of reading those to begin with. Without any codes on where to start diagnosing the problem, all we can do here is speculate.
 

frenchmanfl

Junior Member
22
0
0
Buick Ownership
Buick
Hi HotZ, I just took her to autozone and ran codes (maybe theirs isn't as thorough enough to provide the history etc), the only code kicked up was "evap system", which the guy speculated could be simply due to the gas cap. I had an issue with my former Audi and it was very similar (issues starting after fuel fill) but that thing had 140k miles on it, not 41k. Would the onboard computer not recognize a fuel system issue or could it possibly be as simple as a faulty gas cap or the evap filter? or do I need to, as you say, lug it down to the dealer and have them hook it up (absolute last resort because I simply can't afford the dealer).

Thank you very much for your time and advice.
 

frenchmanfl

Junior Member
22
0
0
Buick Ownership
Buick
ps whether this is related or not, I did open the cap after the codes were run to see if I could identify anything (broken seal etc.), then went off to grab a quick bite. Upon return, she choked up on turnover and I had to gas to get the revs up. Could all of this be a result of a faulty gas cap?

Thank you.
______________________________
 

frenchmanfl

Junior Member
22
0
0
Buick Ownership
Buick
Last note, was out and about, getting her started after fill up is now a staple issue. After I got her started she drove fine for about an hour, but start ups seems to be a problem every time. I also stalled out mid drive, three times. It almost seems like the system is cycling through and at a certain point it gets jammed up but then goes back to being fine. Not fun at all.

Thank you again for hearing me out.
 
1
0
1
Buick Ownership
2014 Buick Regal GS
I think I may be having a similar issue. My 2014 Regal GS Manual Transmission is accelerating extremely rough and stutters for a couple seconds if I am going up a hill or accelerating quickly. Did you ever figure out your issue?
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top