Weird starting issue on 2002 Buick Regal

ohmybuick

Buick Newbie
8
0
0
Buick Ownership
Buick
Hey everyone. I just bought a 2002 Buick Regal LS off an auction (great deal BTW) that starts fine the first time around, but after I drive it for a bit, turn it off, and come back out the Regal doesn't want to start. I have to wait about 15 minutes before it fires up again. I did changed the MAF sensor but am still experiencing this problem.
 

MelsRegal

Full Member
2,799
278
83
Buick Ownership
Regal GS 2017
1. Do you have a check engine light on?
2. Have you done a fuel pressure test, both when cold and when warm, with engine running and after engine is shut off with a few minute wait?
 

txbarney

Full Member
268
2
18
Central Texas
Buick Ownership
Buick
Coil packs are a place to look. A common symptom is "goo" coming out to the base of the coil pack...this is the potting compound on the circuit board overheating and flowing out.
______________________________
 

artiv1976

Buick Newbie
3
1
3
Buick Ownership
Buick
Hey everyone. I just bought a 2002 Buick Regal LS off an auction (great deal BTW) that starts fine the first time around, but after I drive it for a bit, turn it off, and come back out the Regal doesn't want to start. I have to wait about 15 minutes before it fires up again. I did changed the MAF sensor but am still experiencing this problem.
Almost 100% positive it is your fuel pump. Had the same issue last year and after replacing just about everything else fuel and air related it ended up being the pump.
 
Top